The delete all backups of dialog isn’t present when I right-click the folder in question.

I am trying to delete all Time Machine backups of this folder including the ones found in the local snapshots.

  • You question is ambiguous. Are you trying to delete a specific folder, or 'all Time Machine backups' and 'local snapshots'? – IconDaemon Mar 13 at 13:46
  • I am trying to delete a specific folder. – sunknudsen Mar 13 at 14:05
  • Is this a folder in your (or another) user's space, or elsewhere (in System, Library, etc?) – IconDaemon Mar 13 at 14:29
  • It’s a folder in my user space ~. – sunknudsen Mar 13 at 17:22

You must enter Time Machine by going to the menu icon and clicking on it. One of the options is to "Enter Time machine". This will bring up all your backups on the screen. When I right click on a folder I get the options shown below.

enter image description here

enter image description here

If you chose "Delete All Folders " it should do what you want.

  • Thanks for helping out. The problem is that the delete all backups of is not present in that menu (for reference, I am in Time Machine). – sunknudsen Mar 13 at 17:23
  • Maybe the folder is not in any other backups. Have you tried right clicking and on folders in other backups? – jmh Mar 13 at 20:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .