0

I've been experimenting with different macOS mail apps. A key feature for me is being able to use some of the now-muscle-memory keyboard shortcuts that Gmail trained me into. Crucially, Gmail's keyboard shortcuts use only a single key, and macOS's App Shortcuts in the Keyboard Preferences Pane require shortcuts of at least two keys.

I was able to use info found elsewhere on Ask Different to add single-key bindings for Outlook the other day, but have since found other troubles with Outlook that forced me to return to Mail.app.

However, the equivalent command(s) (e.g., defaults write com.apple.mail NSUserKeyEquivalents or defaults write -app Mail NSUserKeyEquivalents) have failed to actually change Mail.app's keyboard shortcuts, despite restarting the app and the Mac.

My test case is currently remapping Archive to e. I have tried...

defaults write com.apple.mail NSUserKeyEquivalents '{
    "Archive"="e"
}'

defaults write com.apple.mail NSUserKeyEquivalents "Archive" "e"

And a few other variants. These actually seemed to work, because defaults read defaults read com.apple.mail NSUserKeyEquivalents returned

{
    Archive = e;
}

But, as suggested above, the actual app ignores these keybindings and persists to use the default (^a).

I'm running macOS Mojave 10.14.3 and the latest version of Mail.app. Any ideas? Have I missed something about recent macOS editions ignoring these key bindings for Apple apps or something?

  • For the record, I have tried installing a bundle to solve the problem (github.com/ironfish/Gapple), to no avail. In retrospect someone else posted an Issue to the Gapple repo to say it stopped working a year after ironfish posted it. I've also considered trying the GMailinator-Xcode workaround discussed here but I don't actually desire every keyboard shortcut from Gmail, only a handful I use frequently. – ryanjamurphy Mar 13 at 12:14

You must log in to answer this question.

Browse other questions tagged .