7

I'm experiencing a very annoying issue (Mojave 10.14.1).

When I am staying at a hotel (which I do frequently for work), my computer constantly pairs with devices called "Broadcom Bluetooth Device". It doesn't just discover them - it automatically pairs with them and immediately interferes with legitimate connections to my AirPods or other bluetooth headphones. It breaks and chops the audio into complete, unintelligible, stuttering uselessness.

enter image description here

I have to manually disconnect these things every 1-2 minutes.

I've looked for a few solutions:

  • One mentions turning Handoff "off". My Handoff is, in fact, off.

  • Another mentions that this issue only crops up when a browser window is open; this happens to me regardless.

  • Another mentions using Terminal to 'sudo write' the DontPageAudioDevices value in the bluetooth .plist file in my library to '1'. I have done this, and it fixed the problem partially: the connections to this device have become less frequent, and my computer will automatically disconnect after a few seconds, but usually not quick enough to prevent it from disrupting my audio just the same.

I'm running out of places to treasure hunt for a solution. I don't know why my computer is so stubbornly determined to connect to these random, unknown devices to the point of disrupting fundamental user experience.

Does anybody have a legit solution to force my computer to cease this behavior? This seems like a massive bug that doesn't have a lot of attention. Any help is appreciated.

2

Running Mojave 10.14.5 and also experiencing the EXACT same issues as described.

Currently tried deleting bluetooth preferences files, resetting the bluetooth module, and restarting my macbook to see if I run into the same issues.

If same issues persist, then hotel rooms may be a pain in the a** till a concrete solution is found.


UPDATE


Followed answer in this post to add a MAC address to the "IgnoredDevices" in the bluetooth.plist file and it seems to be working.

Using the terminal, Type sudo defaults write /Library/Preferences/com.apple.Bluetooth.plist IgnoredDevices -array-add ''

Good Luck!

1
  • 3
    This doesn't work for me, because I'm getting hit by multiple MAC addrs - they keep changing, or I'm being attacked from several different devices. Why does Mojave allow unpaired Bluetooth devices to take over my audio - sounds like a security issue to me. – D Mac Jul 24 '19 at 17:13
1

If you're in a hotel room, look on the back of the TV. You may find a device bolted back there serving up games, movies, etc. Pull the power connection. Go to your bluetooth menu and disconnect the connection, if it's still there. Problem solved.
I've confirmed that this was in fact the case in my hotel room recently. I was able to turn the problem on and off simply by cycling the TV device. I'm guessing they want you to play stuff through the TV from your computer. Nothing overtly nefarious - just sort of thoughtless on their part. Granted, Apple shouldn't allow this - you should be aware of and in control of any device that wants to connect to your computer.
enter image description here

1
  • Yeah this is ridiculous. Why in the world would my computer automatically pair with an unknown device with no interaction from me telling it that I trust that other device? That seems like a MAJOR problem. – theferrit32 Feb 8 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .