I have just reinstalled OS X on my Macbook, I'm trying to get homebrew to install subversion, but I encounter the following error:

"Warning: You are using macOS 10.9. We (and Apple) do not provide support for this old version. YOu will encounter build failures with some formulae."

  • 2
    You are overthinking the error message. It is referring to macOS 10.9 as a whole being unsupported, not specifically 10.9.0 or 10.9.5. – tubedogg Mar 11 '19 at 18:46
  • 1
    10.9 [.5 or otherwise] went end of life in 2016. Few developers will currently actively support anything older than 10.12, though some may passively support it, until it breaks. – Tetsujin Mar 11 '19 at 19:10
  • @tubedogg so basically you're saying that I need to upgrade? I already have all the latest updates installed. – AlphaCentauri Mar 11 '19 at 19:15
  • Perhaps one of you can contribute an answer from your comment? That's spot on – grg Mar 11 '19 at 19:16

OS X 10.9 (Mavericks) is almost 5 years old, and has been unsupported since September 2016.

You'll likely want to upgrade to macOS Mojave.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .