I have a MacBook Pro running 10.6.8. It has all the latest updates (except for an item each for iTunes and Safari). Having not used Mail for a week or so, I've run into some problems with it - plus similar problems with Colloquy and LimeChat (both IRC clients). For all three, the problem is that the screen is not being redrawn; it appears to be acting transparently, and so screen furniture (scrollbars etc) are leaving a trail where the application content should be.

enter image description here

I've tried an array of things to fix it - obviously tried rebooting, and also shutting down fully before turning back on.

Also, I've deleted ~/Library/Preferences/info.colloquy.plist, with no change in Colloquy's behaviour. To be honest I'd not expect it to be an individual application issue, since it is affecting these three applications.

I've tried a few graphics things too. I've turned off the energy saving graphics mode in the Energy Preferences pane (although it has worked since new with that feature enabled). I was also running gfxCardStatus, now removed from the boot sequence and not running.

I've tried removing most things from opening at login, again to no avail. I've tried a new user account, and the same problems are exhibited in LimeChat. Not yet tried Mail in the second account - will do so - but am not hopeful.

As a long shot, my colleague suggests that I try verifying my primary (only) disk, and this turns out to be fine (verifying permissions as I type all disk permissions have been fixed, no change).

The last thing I installed was a modem driver, but it's been working fine with this, so I don't think it was that that has upset the system. Not sure I've done anything differently that might have caused this, tbh. So... I am now a bit stuck. Any ideas?

Edit: just tried Adium as well, another chat client. Same redraw problems again!

1 Answer 1


Fixed it!

I installed the pending update for Safari, which I thought was quite irrelevant, and that has sorted it out. Initially I thought that this did some system 'tidying up', which kicked a graphics module back into shape. But a colleague points out that Mail may well use WebKit's rendering engine, and it is possible that all of the IRC clients I tried also do.

The problem is still most strange, as the update for Safari has been pending for a great deal longer than the problem, which must have cropped up around ten days ago or less. So it was working without that update, and furthermore I've not idea what I did to trigger the fault.

Still, sorted now. Hopefully this post will be useful for anyone who encounters a similar problem.

Lightbulb moment: I seem to remember that I used the Software Update feature to download but not install the Safari update (5.1.2) between Mail working and breaking. Since the update required a restart to install, I left it and forgot about it. My guess is that, although it appeared to just download the Safari update, in fact it modified (and broke) the current configuration. If I can find a way to feedback to Bad Apple (tm), then I'll do so. Feedback done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .