0

I ran into a weird problem involving the synchronisation of contacts between Outlook (on a Windows Computer), an iPhone and an iPad.

It all began when I had to do a couple of changes to a number of contacts in Outlook on PC. I had to switch a couple of names (first-/last name). The changes did sync on the iPad without any issues. The contacts on the iPhone however remained unchanged. When I tried to Change the contacts manually on the iPhone a duplicate was created in Outlook as well as on the iPad.

It seems like the problem is for the iPhone to download the contact data from the Server.

Here are some specs of the devices.

iPad OS: iOS 11.4.1 iPhone OS: iOS 12.1.4

Does anyone have an idea how to fix that issue?

1

I hate to be the bearer of bad news but I have seen a lot of weird sync issues between iOS devices and Outlook/Exchange. As an FYI I am the admin for our 2013 MS Exchange server, so I see a fair amount of these.

Very little of what makes sense to do works reliably. I gather there is some kind of issue with Activesync on iOS devices and I have seen where some people claim it is an Apple bug and some, Microsoft's problem. The end result being it never gets fixed (so far...)

You can try the standard things with this, removing and then re-adding the account on the problematic phone, resetting network settings, doing a backup - reset - restore on that iOS device too; all are as likely to work as anything else.

The only permanent solution to the problem that I have found, and this may not be an option for some people, is to use Microsoft's free iOS Outlook email client rather than the email, contacts, calendar apps that come with iOS. I switched over a couple of years ago and completely stopped having sync and account issues with my Exchange-based (work email) email. And actually Outlook is a pretty good iOS email client.

  • Ok, I'll probably try the reset method on the phone next. It just seems weird to me that only the iPhone, but not the iPad is affected, especially considering the phone actually has the newer OS. – Andrew Mar 11 at 19:48
  • Same thing has happened to many people at work, it is a persistent and capricious bug that is difficult to repeat – Steve Chambers Mar 11 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .