0

I have an external hard drive with 3 partitions partitions a exFAT connected to a Windows 10 PC. I am able to mount and access the disks on my Mac wirelessly but cannot get TimeMachine to use this partition as a TimeMachine backup disk.

I am mounting it on my Mac using smb://XXX.XXX.XXX.XXX. I have also tried changing the unsafe disk property using the terminal command:

sudo defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

Anyone have any ideas how to get this to work?

0

Actually you are missing only one thing, TimeMachine will ONLY write to an HFS+ formatted disk so you need to backup to a sparseimage disk image file.

Create the sparseimage disk image with Disk Utility, be sure to select the image type as Sparse Image and the format as HFS+. Make it as big as the partition you are putting it on less a bit. The created disk image will only be a couple hundred MB.

If you are on Mojave even if you select HFS+ as the disk image it may be created as an APFS format. So you will need to mount the image, select it in Disk Utility and reformat it as HFS+.

Now you need to go into terminal and tell TimeMachine about the new backup volume that you have mounted from the SMB share:

sudo tmutil setdestination "/Volumes/TimeMachineBackups/"

Where "TimeMachineBackups" is the name of your mounted Time Machine disk image.

Now just set that volume to mount at startup under System Preferences > Users > Startup Items and you should be good to go.

I recently did this at work and it works great.

  • Thank you this seemed to work! Only issue I have is when I close my MBP I have to play around to get the image mounted again (the drive goes to sleep attached to the PC and I'm guessing this has to do with it). Do you know if I can attach the external drive to my Mac to speed up the initial backup and then go back to wireless without issue? – Blizzardman Mar 18 at 14:45
  • Yah Macs and mounted network volumes have always been problematic for me since the Classic Mac OS days. Mapped drives in Windows just work but I have never had the same success with mounted network volumes on macOS. annoying! Not sure about plugging that drive in locally first, never tried it. – Steve Chambers Mar 18 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .