2

Recently I bought a second hand iPhone 8. When I'm trying to unlock the device It shows this error: The Apple ID "example@email.com" cannot be used to unlock this iPhone

  • Previous user deleted this device from "find my iPhone" service (But still it shows "Erase requested 1hour ago")

How can I register my device under my apple ID? Do they take more time to erase a device from the database ?

  • Is the iPhone connected to a WiFi or a cellular network? Without a network connection the request from "Find my iPhone" can not reach your phone. – nohillside Mar 9 at 14:21
  • @nohillside Yes. It is connected. – isuruAb Mar 10 at 11:06
2

Apple’s activation servers are generally instant. I’ve gone through the official process maybe 20 times in the past two years for work, and it has never not worked within 1 minutes let alone waiting 5.

Here is the official guide and link for the previous user to remove that lock:

Activation Lock is part of the iOS Activation status here:

So if you believe it’s failing, the instructions there are correct - contact Apple Support directly. The only thing I can add, is Apple doesn’t tell you the full email of the previous owner, so unless you have the passcode, you won’t really know which email is “example@email.com” above.

  • How exactly are you connected to the internet from the device to try and unlock / activate it?
  • Do you actually know the email some other way or were you putting something hypothetical in the question?
2

I asked previous owner to enter his Apple ID and Password. After that it gave me a pop up window to add my Apple ID. Now It works correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .