I thought it might help me to color code some of my terminal windows, e.g. made my Redis terminal red.

But setting the color seems to have zero effect on the actual color of the terminal window

enter image description here

The result when the window is activated is still grey

enter image description here

Thanks for any info

1 Answer 1


Just to the right of the colour selector, there's a setting that right now says "Image: Solid Colors". This means that Terminal will grab an image from some system directory containing solid-colour images and use that as a background, overriding whatever background colour you have set. Change that setting to "No image" (or something like that; my Mac is set to Swedish...) and it should work.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .