0

Recently, I have had a problem with highlighting and adding notes in preview. When I highlight, the correct words show up highlighted in the document, but the side panel shows a set of words which is offset by some variable number of characters. Additionally, there is no way for me to edit my note in the sidepanel. And when I try to click on the yellow square of the note, it starts to appear and then disappears very quickly. So I can't actually see the note when I click on it. Sometime if I try clicking many times very quickly the note will pop up and stay and it will allow me to edit.

I have tried quitting/restarting preview; rebooting; many different documents from different websites. All have this problem now.

edit: Another symptom of the problem is that when I highlight text, I can no longer click on any links that were active in the text (e.g. an in-text reference).

Can anyone please help?

Similar to this question, but I'm not seeing duplicate highlights. Just offset highlights and unusable notes behavior.

I am running MacOS High Sierra 10.13.6

  • 1
    I just attempted to add a note to an image in Preview, and Preview went wacky! I don't think I had exactly the same action but it sure wouldn't let me do very much. – jmh Mar 7 at 16:21
  • For anyone having this problem, I have been trying to find a new PDF reader to switch to and after a lot of research I settled on PDFexpert and it seems to have none of these problems. Hopefully Apple still gets their act together if this is a problem on their end though. – spacetyper Mar 13 at 0:57
  • What version of macos are you running? – jmh Mar 13 at 2:25

You must log in to answer this question.

Browse other questions tagged .