1

Problem Description

About 5 years ago, I upgraded the original HDD to SSD (Samsung 840 evo), everything was ok until last November.

After a trip to an examination (4 hours drive, 2 hours out, 2 hours back), when I turn on the power there is a Question Folder mark display on the screen.

Because this one is a spare computer, and there is no important data, so I tried to reinstall OS X. But after a long wait, the computer still cannot boot up, still question folder mark.

When I try to reinstall again,the SSD cannot be found in Install OS X Program or Disk Utility Program. I take off the SDD, connect it to a PC, and delete the partition, those Mac APPs can find it again, but Disk Utility Program cannot erase the disk, the erasing progress will be stuck on somewhere.

I thought this SSD is dead. So I replaced it with a new SSD. Try again, the same problem(After download files, reboot to continue to install will display Question Folder mark).

In addition to these:

I tried to reinstall from Recovery Disk. Still, the same problem.

I tried run Apple Hardware Test, did not find any problem.

After a lot of tries, when I erase the partition, this error popup:

Volume Erase failed

Volume Erase failed with the error:

POSIX reports: The operation couldn't be completed.

Input/output error

Conjecture

When I drive to then examination perhaps some bumps and shakes broke some part in the computer? I don't know.

It seems like the Part of SATA I/O or something on logic board goes wrong?

Update

I installed macOS to an external drive, it workes. I tried several times, and I found maybe the problem is the cable. I order a new cable online, I will try again later.

Update 2

After replacing the cable, problem fixed. :)

1

It sounds like you had a replacement SSD that WAS working at one time and has since failed. You then had some work done on the Mac or had some diagnostics done (?) but with no results.

Trying another SSD yielded similar results: the drive was not found to install macOS onto.

I am re-stating your problem to make sure I got it right.

What it SOUNDS like is that there is something going on with the storage subsystem. A cable, a connector or something on the system board (disk controller or the like).

You could examine all the connections carefully make sure there are no kinks or breaks in any cables associated with the disks. And if you still have the original working drive I would be tempted to try that, assuming it is still around and still bootable.

Failing all of that I would say that the issue is with the Mac itself and if a repair shop can't fix it what you have is an expensive door stop, unless you want to use the Mac with an external drive plugged into it (assuming that works...)

  • Thanks for your answer. I think you got my point, but a little different: new SSD can found to install macOS, but after reboot computer display Question Folder mark, cannot continue to install, and when I try to erase partition to reinstall, It will fail, I have to connect it to PC to erase the partition, after that Mac can found it, but still cannot continue installation. It fails into this endless loop. – Song Mingxu Mar 7 at 3:53
  • Now, I'm trying to install mac into an external drive, see what will happen. – Song Mingxu Mar 7 at 3:54
  • That is VERY strange, I have no idea what is going on there... – Steve Chambers Mar 7 at 13:55
  • 1
    I installed macOS to an external drive, it workes. I tried several times, and I found maybe the problem is the cable. I order a new cable online, I will try again later. – Song Mingxu Mar 7 at 23:43
  • Once you have a working system you may be able to run more diagnostics, etc. to investigate... – Steve Chambers Mar 8 at 0:51
0

Not clear what your problem might be, possibly logic board.

In the boot up sequence the SMC the NVRAM and T2 (which are separate chips on logic board) and play a role in the initial start up.

EFI is a part of the disk.

  • Thanks for your answer, this graph may be helpful. – Song Mingxu Mar 7 at 3:56
  • Does a MBP 2012 have a T2 chip? – Global nomad Mar 8 at 6:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .