0

After a recent software upgrade, opening almost any PDF file I have freezes the entire computer for 15 seconds. The problem is worse for larger files, but present even for tiny files.

The problem is specific to hyperlinks and internal links created by the very common LaTeX package hyperref. This is the default way to create links in LaTeX, and the majority of all files I have to deal with in my work use it. This means I'm spending a significant amount of time every day staring at a frozen computer.

The bug can be consistently triggered using the following simple code:

\documentclass[11pt]{article}
\usepackage{hyperref}
\begin{document}
\hypersetup{pdfborderstyle={/S/U/W 1}}
\url{www.google.com}
\end{document}

Apparently the bug is not specific to Preview, but has to do with the PDF rendering engine on OSX, which all PDF viewers must use. I run into the exact same problem opening the file with Skim. I've tried the usual advice of deleting random cache files in ~/Library given in other questions, but nothing changed.

According to the discussion on the LaTeX StackExchange, this is a known OSX bug and there is no intent to fix it in the near future. I think this is outrageous, but if it won't be fixed, is there a reasonable workaround?

  • Please specify the version of your TeX package and what software upgrade did you do (OSX ? version?) – Yoan Mar 6 at 9:10
  • @Yoan The OSX version is the most recent one, 10.14.3. The TeX distribution I am using is TeX Live 2018 with all packages updated to the most recent version. – knzhou Mar 6 at 16:47
  • I cannot reproduce your problem. The code snippet provided by you works perfectly; however a small problem: just add the http:// prefix to your url. With this, your code open safari and google page. I have the same versions as you - I asked because some old versions had some problems with paths on OSX. – Yoan Mar 7 at 8:07
  • @Yoan Here is an example that triggers the bug for me every time. It's okay in the browser, but freezes if you download a copy and open with either Skim or Preview. – knzhou Mar 8 at 16:43
  • I have downloaded the paper from the link and works perfectly in Preview. it opens also the first mail address for example and prepares Mail correctly. Do you have some third-party applications for supplementary macOS configuration? – Yoan Mar 9 at 16:24
1

As of the latest OS X update (4/23/19), this problem has been resolved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .