0

I'm switching from a local backup disk to a local .sparsebundle so that I can easily save the encrypted .sparsebundle to remote storage.

The following works:

  • Mount the sparse bundle to /Volumes/foo
  • tmutil setdestination /Volumes/foo
  • Run backup

The .sparsebundle is on an external disk like /Volumes/bar/foo.sparsebundle. If I point Time Machine at bar as the backup destination, I get the following error:

Time Machine couldn't complete the backup to "foo". The backup disk image /Volumes/bar/foo.sparsebundle" could not be accessed (error 45).

This same machine is a backup host for other macs on my network. I have compared the format of their .sparsebundles and they seem to be very similar. The local has "Owners: Enabled" while the remotes have "Owners: Disabled" in Disk Utility. When I mount a remote .sparsebundle I am the owner of all the files. When I mount the local, they have the same ownership as the source disk.

How can I get Time Machine to automatically mount my local .sparsebundle?

  • 1
    I had a problem where a newly created sparsebundle was actually APFS instead of HFS+ even though I specified HFS+ when creating it. I had to reformat it once it was created, so check that with disk utility, it could be an issue. – Steve Chambers Mar 5 at 20:26
  • Thanks for the suggestion. This one is Mac OS Extended (Journaled). My other backups are also case sensitive, but it seems like Time Machine never mounts the .sparsebundle so it seems unlikely this is the issue. – chmac Mar 5 at 20:39

You must log in to answer this question.

Browse other questions tagged .