1

Ive been rattled out of my mind for the past few days. What started the issue was a random kernel panic that rest all my dock settings. initially i thought it would be due fixed on restart, however no preferences are saved at all.

Steps i have tried

I ran Killall Dock but it just resets it to default. Tried to locate com.apple.Dock.plist and delete it but initially there was no file which is strange. So i copied the sc from the apple website and recreated the file and placed it in ./library/application support/dock Still no solution

another thing to note was that my VsCode was giving me a write error to the same folder which i fixed by deleting the old code folder

Specs: MBA 2015 on High Sierra

  • Have you run First Aid from Disk Utility yet? That would seem an obvious first step. Test another account to see if the same happens. Remove any 3rd party kexts. Reinstall the OS from Recovery. – Tetsujin Mar 5 at 10:05
  • @Tetsujin I managed to screw it up even more. I updated to the developer beta 4 and my terminal bricked. Fixed that now and am coming back to this issue – Shane Mar 5 at 10:30
  • Well... take solace in the fact it's not the beta 4 itself. I'm on it too, with no real issues. – Tetsujin Mar 5 at 10:41
1

Since no one found an answer im gonna post my solution

The initial error that affected a bunch of other applications was a mismatch in the write permissions on the ~/Library/Application Support/ folder I deleted the said folder and restarted the application as the write permissions were not an issue in the get info section

Afterward my terminal froze . so i set it to bash/sh to fix it KillAll dock and it worked. I cant exaclty explain what the issue was but i suggest that the system couldnt read the com.apple.Dock.plist

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .