Update: There is no solution. After I got the .qtz file into /Library/Compositions, it didn't work, and then I found out that third-party visualizers have been disabled as of iTunes 12.6. It may still work on previous iTunes versions, but I do not know.

On 10.12.6, I am trying to install an iTunes visualizer, but there's no way to progress past this screen.

Package installation screen with greyed-out "Continue" button

It is supposed to be installed to /Library/Compositions, so I tried

sudo installer -pkg ~/Downloads/wowlab_oneday_1.0.1/wowlab_oneday_1.0.1.pkg -target /Library/Compositions

The result was:

installer: Error trying to locate volume at /Library/Compositions

The same error occurred regardless of the destination specified.

These are the files Installer wants to install:

Files inside .pkg, containing a .qtz file

When I expand wowlab_oneday_1.0.1.pkg with Unarchiver, it contains a Resources folder, Distribution file, and wowlaboneday.pkg. This second .pkg can't be extracted with Unarchiver. When I click Show Package Contents, it contains Bom, PackageInfo, and Payload.

How can I get the .qtz file out and into /Library/Compositions, presuming that's what needs to be done?


From man installer:

 installer ... -package <pathToPackage> -target device


A device parameter for the target is any one of the following:

 1) Any of the values returned by -dominfo
 2) The device node entry.  Any entry of the form of /dev/disk*.  ex: /dev/disk2
 3) The disk identifier.  Any entry of the form of disk*.  ex: disk1s9
 4) The volume mount point.  Any entry of the form of /Volumes/Mountpoint.  ex: /Volumes/Untitled
 5) The volume UUID.  ex: 376C4046-083E-334F-AF08-62FAFBC4E352

So try sudo installer ... -target / instead.

If this fails there is also the option of using Pacifist to extract the content of the package and install it manually (or do whatever you like to do with it).

  • Unfortunately this returns the even more ominous "installer: Cannot install on volume / because it is disabled." Upon googling, this may be a lost cause, because that error is usually related to whatever hardware/software requirements the application specifies. It's from 2009 and was intended for 10.5+ so I don't know how I'd go about forcing it to install on 10.12, if that was the cause of the problem. Mar 4 '19 at 10:26
  • @DorianhaBogelund You could try Pacifist to extract the content from the PKG. But it may very well be that the plugin is too old.
    – nohillside
    Mar 4 '19 at 10:29
  • Good software, was able to extract the file, but then sadly found out that all third-party visualizers have been disallowed in recent iTunes versions. Thanks for your help though! I will now be trying other ways to use this file with system audio as the input. So it was very helpful to be able to extract the .qtz! Mar 4 '19 at 12:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .