I've seen similar answered questions like this.

I'm unable to boot into my MacOS partition.

Long story short, I had Windows BootCamp, removed it and then later installed Ubuntu Linux, then tried to delete the Linux partition and I think I ended up deleting the Boot recovery partition. And then tried to run repair, and now my main mac partition now shows FFFFFFF something.

My Macbook is this one https://everymac.com/systems/apple/macbook_pro/specs/macbook-pro-core-i5-2.6-13-mid-2014-retina-display-specs.html#macspecs1

I'm guessing my Macbook got updated to Mojave 10.14 before this happened but I'm not 100% sure of it, it may be on High Sierra but I'm guessing.

I'm booting into Internet Recovery and this is what I've pulled up in the pictures below.

I would like to be able to boot into my regular Mac OS partition.

  1. I'm unable to figure out if the partition is a OS X Standard Partition or CoreStorage or APFS or etc.
  2. Is my recovery boot system too old if I need to use gpt to set it to an APFS argument?
  3. Should I check if the EFI partition and the Recovery HD partition are corrupted
  4. Would the 650 MB boot/recovery partion always be the last 650 MB of the disk
  5. Does the partition table contains an MBR instead of an PMBR and would the MBR need to be replaced by a PMBR?
  6. Previously the main MacOS partition was resized by me, how and when would be the best time and way for me to resize it to occupy the entire free space like stock?

Please Help.

It default boots into this. enter image description here If type exit, I get this. enter image description here Holding Option on boot shows enter image description here

This is rest of the stuff I pulled from internet recovery

enter image description here enter image description here

enter image description here enter image description here

Please Help!

  • @klanomath Please can you help!
    – Farhan3
    Mar 4 '19 at 5:52
  • Can I assume you have a second working computer? If so, what kind of computer? What is the operating system? Do you have a flash drive you can reuse? If so, what size? Posting of the output from dd if=/dev/disk0s2 count=3 | vis -c might be helpful. Mar 4 '19 at 10:45
  • @DavidAnderson I have a second working computer with working windows and ubuntu. I have a 128 GB flash drive I can reuse. The last image has the output of dd if=/dev/disk0s2 count=3 | vis -c. If you need anything else please do let me know.
    – Farhan3
    Mar 4 '19 at 18:59
  • Did ever successfully fix your Mac? Mar 7 '19 at 2:52

Based on klanomath's answer to the question OS volume shows as type 'FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF', it would appear you are missing a APFS type partition.

I believe you should enter the following commands while booted to Recovery Mode. See klanomath's answer for an explanation.

diskutil unmountdisk disk0
gpt remove -i 2 /dev/disk0
diskutil unmountdisk disk0
gpt add -i 2 -b 409640 -s 168232920 -t 7C3457EF-0000-11AA-AA11-00306543ECAC /dev/disk0
  • You will still have Grub and Windows boot files stored your EFI partition. Once you can boot to macOS, you may want to address this issue. Mar 5 '19 at 0:32

Not the answer you're looking for? Browse other questions tagged .