5

In the past two days I've tried to make an in app purchase in two apps*. I've successfully made purchases in the past, but not with these apps, and both times yesterday and today I've gotten an odd failure. I'm using an iPhone XS Max.

Here's what I do:

  1. Click on remove adds in either app, which gives the "Double click to pay" dialogue.

  2. Double click the side button

  3. Face ID checks and gives a checkmark with "Done" below

  4. Then I get this Verification Required

  5. Continue takes me to Settings, checks Face ID and shows my billing information with the CVV not filled in.

  6. Input CVV and click Done, I get another Face ID check and get thisSign In to iTunes Store

Both Cancel and Buy seem to do the same thing at this point, just drop me back to the Account Settings page.

That "%%appleId%%" seems super sketchy. I'm keeping an eye on my credit card and haven't seen any weird charges. If I manually follow the path from the first dialogue I get to the same "Account Settings" page and get the same dialogue with "%%appleId%%"

Otherwise, this seems like it could be a bug. Can I do anything to get around this %%appleId%% error dialog where it won’t let me enter my password or make a purchase?

*(removing ads for both Sudoku Master Edition and Wordscapes)

5

I had this happen to me and what worked was intentionally failing the Touch ID (or face I think it doesnt matter) so it gives you the option to type in your apple id password

  • Genius! I had to do this on a couple of different Touch ID dialogs but it eventually broke me out of the stupid cycle. Thanks! – Perry Mar 6 at 1:55
3

This happened to me as well a few days ago. I fixed it by turning off the passcode to unlock the iPad (which required me to enter the apple id password) and turning off Face Time for App Store purchases. Then I turned passcode back on (which again required my apple id password). Then when I went to do an in-app purchase it failed, required verification, but this time it actually asked for a password rather than giving the "%%appleId%%" error. The in-app purchased completed. I then turned face time back on for App Store purchases and now face time works just great for in-app purchases, no errors or failed verifications anymore.

As a developer, this has got to be happening to more folks than just us. You'd think Apple would have maetris that would be showing a general drop in in app purchases, but not a corresponding drop to app purchases and they would track the problem down and fix it.

There are also anecdotal reports that you might have to fail your fingerprint / Face ID or disable / re-enable more than once to clear this error condition. On most, the first fix works, though.

3
+50

I went to System Preferences > Face ID and Passcode (which required me to enter my device password) and turned off Face ID for the App Store.

Once I did that, I attempted to make an in app purchase and was again sent to verify my info, but this time was able to do this successfully after inputting my CVV.

I then turned FaceID back on for the AppStore.

  • 1
    this was inspired by @sembiance's answer but after reading it closely every step was actually different, so I went ahead and posted this answer. – dwightk Mar 5 at 18:07
2

You can intentionally fail the FaceID or turn off FaceID for AppStore. Both answers are correct.

But you can also turn off FaceID and after the purchase set it up again. This will regenerate your tokens definitely preventing this to happen again.

1

I ran into this issue trying to make an in-app purchase on Foreign Numbers and neither of the above solutions worked for me unfortunately.

For me, I was able to make an in-app purchase with no troubles after rebooting my iPhone XS Plus. The in-app purchase seemed to take a little longer to initialise, so maybe that was a good sign...?

In any case, this doesn't seem to be the fault of any developer, I believe it's on Apple's end.

1

I turned off all Touch ID here (System Preferences > Touch ID & Passcode) and then it worked. And then I turned the all back on.

You must log in to answer this question.

protected by Community Mar 14 at 2:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .