after 4 months I turned on my MacBook Air [2015] and first off all I tried install JDK 8 and Eclipse for developing python. after all things done, I notified by app store update notification so I clicked to update all of applications. but this things happened.

  1. after downloading all files, iTunes 12.8.2, Safari 12.0.3 and Security Update 2019-001 10.12.6 it shows this message:
    so I clicked on download & restart
  2. ok, now everything is good and waiting for progress bar to complete:
    anytime I tried after failure restart, it started at 1.12 Gb!
  3. and after downloading things wait for restart:
  4. it shows OS update progress:
    but wait, it's good just for 5 secondes
  5. and error happened :
    and I clicked restart
  6. MacBook restarted and go to MacOS again
  7. and now this message showing up:
  8. and now if i click on install, it goes to step one again. and everything repeated as I said in this list.

Machine Specs:

  • MacOS Sierra 10.12.6
  • MacBook Air (13 inch - early 2015)
  • 8Gb DDR3
  • and about 20Gb free space
  • Did you successfully install JDK8 and Eclipse ? Do you think those have anything to do with Safari ? Was the Safari running at the time ?
    – Ruskes
    Commented Mar 3, 2019 at 19:52
  • 1
    @Ruskes yes I installed it and now everything is good. I don't think any relation between this problem and jdk, because i uninstalled those two apps and everything is like past. nothing chaned
    – Netmoon
    Commented Mar 7, 2019 at 6:19

1 Answer 1


Somehow your installed copy of Safari became corrupted.

Delete Safari, then reinstall your current version of macOS. That will reinstall a good copy of Safari, and then you should be able to install any updates.

  • I'll try. but how can I do that. I searched for safari uninstallation but I found some third party apps. I don't want to use that apps. why there is no built-in tool for MacOS apps removal
    – Netmoon
    Commented Mar 7, 2019 at 6:26
  • There is no built-in tool for macOS app removal because none is needed. To delete an app, just drag it to the Trash icon on your Dock. Commented Mar 13, 2019 at 19:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .