2

I deleted an app from the Applications folder. However the original app icon in the Dock is now appearing as a '?'. I am unable to delete this icon from the dock, when I click to get the Options menu, I dont see any sub-items. I am unable to drag this icon into trash as well. Any ideas as to how this can be done?

Running Mojave: 10.14.3

  • Did you try restarting the Dock by running killall dock. – Nimesh Neema Mar 3 at 17:05
  • 1
    @Nimesh Neema, the killall dock command will just return No matching processes belonging to you were found, you need to use the proper spelling of the target app, e.g.: killall Dock – user3439894 Mar 3 at 17:21
  • Yes, I had tried the killall Dock, that doesnt fix the issue. After the dock gets relaunched I can still see the '?' icon. – mithrandir Mar 3 at 17:23
  • If you have Xcode installed, you can delete the app target key from the persistent-apps in the ~/Library/Preferences/com.apple.dock.plist file and then use killall Dock, or you can just delete the com.apple.dock.plist file followed by killall Dock; however, the latter resets the Dock to the macOS installed layout. Which is why removing the target app from the plist file may be more suitable. – user3439894 Mar 3 at 17:32
  • Just left-click hold & drag it out into the desktop. should give you a Remove option. Let go, done. – Tetsujin Mar 3 at 17:35
-2

Drag the icon off the dock (not into the trash) and hold it for a second until it says "Remove". Then drop the item and it should go away.

enter image description here

  • The OP stated in comments that he has already tried that and its not working. Also under normal circumstances dragging to the Trash should bring up the Remove from Dock command but it obviously hasn't worked for the OP in this instance. – user3439894 Mar 3 at 21:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .