My MacBook Air is stuck in boot loop i.e. When I start my mac I see apple logo for some secs and the restarts again. This happens over and over. I can't get to os. When I try to get to utility disk using command+R, it doesn't get there either as it keeps restarting. Any idea how can I fix this?


When I try verbose mode I get this



Here are the screenshots. I'm not sure where it gets stuck but the first one is where it takes few extra seconds before it gets going further and the second screenshot is when trying to restart. enter image description here

enter image description here


Based on @Ruskes answer, I created a bootable usb from another mac. And I boots infected mac from it but when it restarts the same restart loop began.

  • did you try Safe mode ? – Ruskes Mar 2 '19 at 16:33
  • Yes and it doesn't get there either. It stays on apple logo at the startup. – null Mar 2 '19 at 16:34
  • and the Internet recovery does not work either ? or the Verbose mode ? – Ruskes Mar 2 '19 at 16:43
  • Internet recovery when I try, I see list of wifi and I select one it waits for few moments and then restarts and again the loop of restarts begins. How can I get to verbose mode? – null Mar 2 '19 at 16:48
  • 1
    That would not help, you will need to download the OSX (Mojave or similar) then create a bootable USB, the process can take hours. Since your Hard Drive is probably damaged, you might want to consider going to Apple Service, they will give you FREE diagnosis and cost estimate to fix it. – Ruskes Mar 2 '19 at 18:05

Start with the basics: PRAM reset and then check the drive/filesystem (below)

Boot your system while holding command-S. Hopefully it will bring you to a command prompt. You can then run these commands to check/repair the file system, and reboot

/sbin/fsck -fy

You may also want to run hardware diagnostics on your mac.

| improve this answer | |
  • Thank you the answer. It took me to command prompt and that command gives me this output. m.imgur.com/gallery/V6hpdHF – null Mar 3 '19 at 16:50
  • I tried to delete files in cache using this blog mklibrary.com/technology/… by going into terminal using above method but it says operation not permitted. Any why is that? – null Mar 6 '19 at 13:17
  • The imgur link doesn't work. What is the error? – Hefewe1zen Mar 7 '19 at 16:14
  • They are all read only file system. Thats what is says. It can not be deleted, Read only file system – null Mar 7 '19 at 17:01
  • This is via single user mode? You'll have to mount the file system as read-write before attempting changes. Single user mode will tell you what to do when it drops to the prompt: "/sbin/fsck -fy" then "/sbin/mount -uw /" – Hefewe1zen Mar 7 '19 at 17:04

Here is the typical boot up sequence. Yours seems to be stuck at the "Secure Boot" point. Recommend to completely wipe the disk and start over.

enter image description here

| improve this answer | |
  • How can I completely wipe my disk as I cannot go to disk recovery etc modes.. – null Mar 7 '19 at 17:40
  • 1
    use External (USB) with OSX on it – Ruskes Mar 7 '19 at 17:58
  • would this work support.apple.com/en-ca/HT201372 – null Mar 7 '19 at 18:04
  • @null exactly you got it – Ruskes Mar 7 '19 at 18:05
  • Even this didn't work. I created a bootable USB from another mac. Tried to boot infected mac using bootable USB but when I choose to boot from usb it reboots and keeps restarting. Same loop. – null Mar 8 '19 at 13:12

Probably the best way is the toughest: Forget the current disk inside the mac. Replace it with a new one. Boot from an external disk containing OSX and install OSX on the new inserted disk. Copy all files from Icloud or your backup back. Not the easiest way, but it should work. And as this needs replacing, i would visit the apple store.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .