When I go to the App Store on my iPhone 4s, the password box pops up, but the keyboard to enter the password does not pop up, so I have no way to enter a password. Any idea how I can correct this?

  • Did you try restarting your iPhone? – nohillside Jan 2 '12 at 14:57
  • 6
    Did you tap the text input to enable focus on it? – Gerry Jan 2 '12 at 16:10

Close the app, double-click the home button to bring up the currently running apps, and hold down on the App Store until they bounce. Then kill it.

Then you can go back into it.

I've had a bunch of issues like this with the App Store app. sometimes I don't get the update button for apps, or no keyboard, etc. Restarting the app afresh sorts it out.

A total phone restart should also work.


I solved the problem on my jailbroke iPhone 4S.
I opened 'ColourKeyboard' and went into the 'Respring' option, after respringing my App Store keyboard appeared and worked fine. You can check it by going into the App Store app and looking in the 'Featured' section then go into 'Apple ID' then 'View Apple ID'.

Hope it works for you

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .