0

I have a 2012 MacBook Pro with a 500GB Samsung SSD running Mojave. I replaced the optical drive with a hard drive and everything worked fine.

Recently, I replaced the old hard drive in the optical bay with a new HP 128GB SSD. With the HDD, my boot time was around 14 seconds. Now, with the SSD, it hangs for a second and then opens Disk Utility. I tried to click anything in Disk Utility and it continues to hang again.

I am about to pull it apart in frustration and format the darn thing with my clone cable. What could be causing the hanging and how should I format it if I am only storing code?

1

The "hang" is most likely caused by the HP SSD being pre-formatted for Windows computers (NTFS) which macOS cannot read by default. If you wipe the drive with a macOS compatible format, it will likely fix the issue.

Using Terminal, issue the following command:

$ diskutil eraseDisk HFS+ Untitled GPT /dev/diskX
  • HFS+ is the format of the new drive
  • Untitled is the name of the new drive
  • GPT is the partition scheme
  • /dev/diskX is the drive identifier (use diskutil list to obtain identifier)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .