I have an iPhone 4 that is showing its age. It will charge when plugged into the wall charger. However, when I plug the same cable into a USB port on my computer it will not charge or be recognized at all by iTunes.

When I plug my new iPhone 4S into the same cable it is recognized and syncs just fine.

Is there anything I can try to get the iPhone 4 syncing via USB so I can update the OS and sync with iTunes, etc?

Edit: I will occasionally get the "This accessory is not optimized for this iPhone" message when I plug the iPhone into the cable connected to the USB port.

  • can you please any further informations like OS/notebook or pc/etc.? And did you try another USB port or another computer? Commented Jan 2, 2012 at 14:07
  • I've tried multiple USB ports and computers - MacBook Pro (Lion), Windows 7. iPhone OS is 4.3.3.
    – Dave
    Commented Jan 2, 2012 at 14:14
  • So are you using Lion or Windows 7?
    – Gerry
    Commented Jan 2, 2012 at 14:24
  • I've tried both but currently trying Windows 7. I can try to sync on either one.
    – Dave
    Commented Jan 2, 2012 at 14:24
  • Does iTunes have a record / backup of the phone from when it worked? Maybe the record is messed up or iTunes is confused with the two phones.
    – Richard
    Commented Jan 2, 2012 at 16:28

6 Answers 6


I know, in most cases, this problem to be the usb port on the iphone. Unfortunately this part seems to be a part which only one in five of these parts to be good from experience. Either the mic or data port are defective which makes a diy repair frustrating. Most people will change it once they hit a defect part and give up. Don't give up. Trying to help people who are frustrated as I was. Usually occurs when you update with a port having bad contacts and ends up with a no sync or no voice on phone mic. May not be what you want to hear.


I was having the same problem- tried everything (quick cleaning, new cables; both wall and computer cables, etc.). I was convinced it was a software problem and was super pissed at apple. Then I took a flashlight and looked at my phone's connector contacts (on the far right and left of the "row of information pins". I noticed, even after cleaning, there was still some lint or dirt. So I bought some Cyber Clean (Swiss formula)- its a yellow gel-like substance. I turned off my phone and literally smashed it into the bottom end and pulled it out and it was COVERED with lint. I did this probably 30 times and was AMAZED at how much lint came out. Now the phone charges like new. I would highly recommend buying that stuff before investing in a new phone. You can really jam it in, even to the point where it breaks off. Then it will reattach to the main mass so you can pull it out. Good luck!


As others mentioned here, the problem is most likely dust and lint in the connector interfering with the data pins. It will prevent charging while connected to a computer.

I had the same problem and fixed it by folding over some Scotch tape, sticky side out, and sweeping it inside the connector until the lint was cleared. Then I inserted and removed the cable connector about 20 times just to make some friction and clear the pins and that did the trick (be sure you unplug the USB side from the computer for that).


If the phone is intermittently recognised as something being there that iTunes can't work with, I've seen this before.

With my iPhone 3G, somehow I managed to get liquid onto the dock connector port. There was corrosion over the data pins but not the power pins so I could (always) charge at the wall, intermittently charge from my iMac/MBP and very intermittently get iTunes to recognise there was a device. Couldn't get it syncing though.

I waited out the problem with a crappy phone (cheapo £10 job) a few months or so until the iPhone 4 came out. The replacement/repair option from Apple was a refurb 3G for quite a lot of money and I'd been thinking about upgrading anyway.

Things have changed since then in terms of iOS repairs and costs so it's probably worth getting it checked out as the official options have improved since then!


That hapened to me once. Try replacing your USB cable.

  • I've tried at least two USB cables. Both worked with the iphone 4s but not the iphone 4, so same scenario with each one.
    – Dave
    Commented Jan 2, 2012 at 14:44
  • It sounds to me like a hardware failure. If it's under warranty you may send it back and get a new one for free.
    – Jorge
    Commented Jan 2, 2012 at 15:15
  • I second George. Also, if you're using a low-powered USB hub, you run into that problem.
    – Pratik
    Commented Jan 3, 2012 at 22:50
  • this is commonly caused by either third party cables, and non USB 2.0 ports Commented Jan 3, 2012 at 23:04

WARNING: This is probably a bad idea. If you're mostly using the 4S and just want to fix the 4 if you can, and don't mind the chance of it breaking, it's worth a try. This is the position I was in, finding myself with an extra 3GS.

And it may activate the water damage indicator.

If you have warranty coverage, go do that instead.

But if you still want to try this:

  1. Turn the phone completely off.
  2. Unplug both ends of one of your USB cables.
  3. Put a bit of electrical contact cleaner on the iPhone side of the USB cable, NOT the phone itself.
  4. Let it mostly dry.
  5. Work that connector in and out of the iPhone a dozen times or so.
  6. Leave it disconnected for a while, maybe overnight. Find something to distract you. Go to a movie or something. Sherlock Holmes 2 is pretty good.
  7. Plug it all back in.

This will only work if the problem is crap on the iPhone connector, which from your description seems likely. But it may be a problem deep in the iPhone, too.

Note: WD40 is not electrical contact cleaner.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .