1

Two weeks ago, a friend's mid-2012 MacBook Pro gave the dreaded question mark folder upon attempting to wake from sleep. I pulled the drive and checked it (backed up, SMART status passed, 70+ MBps read/write - pretty good for an old 2.5" spinner). I booted to AHT and ran full hardware diagnostics. It came back with no errors. I know that HDD cables in these machines fail regularly, so I replaced the cable with a used one I bought from PowerbookMedic.com. It worked!

About a week later, the exact same thing happened - a flashing question mark on waking from sleep. So my question is:

Could a different piece of hardware be failing/did I overlook something? If so, what? If not, what are the chances that this new cable failed so soon after install? More importantly, if I exchange it for another used cable, what are the odds it will fail quickly again?

Important notes:

  • HDD is known good
  • Once the flashing question mark folder shows up the first time, nothing will boot attached to that cable (attempted with Win10 SSD, macOS HDD, multiple attempts made - the first time this occurred, a cable replacement solved that issue).
  • Computer will still boot and operate effectively from HDD when attached via USB

Please don't hesitate to ask any clarifying questions!

  • Was this a new cable or a used one? The way your question is written it makes it sound like you purchased a used cable which would (IMO) have a much higher chance of failing. – Allan Feb 28 at 19:36
  • @Allan the cable I purchased was used. There aren’t any new ones in stock. Is it worth exchanging it for another one? – NoahL Feb 28 at 19:53
  • 1
    I've purchased them new before from Amazon and thus far, had no issues. – Allan Feb 28 at 20:01
  • Great thing about PowerbookMedic is their guarantee. Ordered the part linked from Amazon above and am getting a full refund + return shipping covered. Thanks, @Allan. – NoahL Mar 1 at 17:00
  • 1
    If it works out, be sure to come back and post an answer and ping me when you do - I'll be happy to up vote! – Allan Mar 1 at 17:17
2

Looks like it was just bad luck. Got a cable from Amazon here as recommended by Allan in the comments and installed it. It's been working for almost a month with no issues.

  • Glad you were able to get it sorted out and for closing the loop! – Allan Mar 21 at 23:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .