1

On my 2011 macbook air i have high sierra installed.

It attempted and at some point completed an update security update 2010-001 to version 10.13.6 (not sure if i had automatic updates on or not).

Because i had disk encryption on, i think it became befouled.

Something like what is discussed here:

http://discussions.apple.com/thread/8092225

forums.developer.apple.com/thread/79420

I now have trouble booting (often it doesnt boot and it takes ages when it does).

I tried clearing the flash with (cmd+optn+P+R) without much help.

On the odd occasion it eventually boots, but as with others on that page everything was going real slow and so i tried to start decrypting the disk (turning off file vault encryption) as others suggested on that page.

Now it is taking a real long time to decrypt. I left it on overnight and had sleep turned off, nevertheless it still locked my computer and i think maybe made no progress over night.

So i got it to boot into my install of windows via bootcamp, and windows works fine. So my question is, should i just use my Mac as a windows machine? or is Apple working on a fix for this problem?

I was able to do a FirstAid via DiskUtility on two different occasions. The first time (before i started decrypting) it came up with errors. The second time after i started decryption, it seemed to complete fine.

I was able to get into recovery mode where i could reinstall the O.S but it wont allow me because indefinite decryption is occuring.

High Sierra is basically not functional/fast now and decrytion is taking forever.

Will i need to wipe the whole disk or will the decryption eventually finish?

  • 1
    Is Windows using encryption? – David Anderson Feb 28 at 7:56
  • i dont think so – jsky Feb 28 at 13:23
  • Why is it acceptable for you to use Window without encryption, but you needed encryption when using macOS? Why not install macOS without encryption and continue to use macOS? – David Anderson Feb 28 at 13:42
  • @DavidAnderson i only use windows rarely for windows dev. i dont have any private data on that volume. and besides, if i knew file vault encryption would f up my volume on update, i may not have used it in the first place. – jsky Mar 1 at 3:25
1

UPDATED ANSWER:

I noticed safe boot (hold shift) WAS working fine with CPU available but limited by the fact it doesnt load everything.

I then did Justin Silvers method of removing older kexts. Particularly previous to that i was only managing kexts under /Library and ~/Library but now i was also removing older ones from /System/Library.

One of the kexts i removed was PACEsupport and i also moved other Mbox2 related old kexts. These were from pre 2015.

But this didnt fix things immediately and not even after restart, but it did force the cache to rebuild itself from scratch as i watch it do so in verbose boot mode (cmd+v).

So i went out to buy a replacement cord as i had given up on fixing the O.S and was going to try to get my old external HD to restore an old snapshot if possible, then suddenly out of the blue it released CPU resources again & now kernel is processing fine again & now i just need to find the correct way to recognise my old external HD.

At the time it released resources it seemed to be processing a lot of QuickLookSatellite processes & i took a snapshot here. As you can see the kernel was using all the CPU (at times up to 1300% or more) and here it falls off the cliff back to 18% seemingly randomly but i think it just finally processed all the kext cache again and maybe some of the removed kexts were no longer preventing it. But i think there were several kexts that were problematic here particularly originally the Commander uninstall kext process was DDoSing the kernel CPU.

enter image description here


UPDATE:

indeed the problem returned. however i was able to fix it by doing the below.

After the disk decryption process finished, i still couldn't reinstall the O.S through recovery boot, because of connection to apple server problems, even after fixing datetime synchronisation problems.

I was however able to get my system functioning again by removing some startup items and daemons that i think were flooding my system CPU usage. I found these via inspecting the console (in utility folder) and by using EtreCheck tool.

Effectively a couple of older kexts were continually polling my O.S kernel (particularly one called Commander, associated with an old WIFI dongle uninstall process and another one associate with an old program called NoSleep that would prevent the O.S from sleeping but was designed for an older O.S).

These mustve been in conflict with kernel changes in high sierra + update. So they were effectively DDOSing my O.S and consequently kernel CPU was flooded. Stopping these and removing a bunch of unneeded kexts seems to have fixed the problem into a functional O.S again. Im unsure if it was only those two kexts or other removed kexts that ultimately fixed the problem, but at least this gives you an idea of what to do if you have the same problem.

Resources:

osxdaily.com/2011/-3/08/remove-an-agent-from-launchd

etrecheck.com

Result: My bootup time became faster but seemingly not yet back to pre-problem speed. However, the O.S is now completely functional again, with idle CPU kernal usage down to minimal and user CPU usage available again.


Originally accepted answer:

strangely enough, i used my windows boot for a few days, and even did a windows update, then i tried to boot Mac again and its working mostly fine now, it still took a bit slower to boot (but not 20 minutes like it was doing before), and the decrypting is not even finished now. So apart from not using the volume for a few days, i have no idea why it is now working seemingly well again. Id suggest if you have a similar problem to look at the links i've posted in the question details. Perhaps just accessing the boot sector with Windows helped fix up some files or perhaps it was the last First Aid i was manage to do which didnt immediately fix it but mayve fixed it but took a few boots for me to realise. its also possible the problem is not fully fixed and will return but im offering this as the answer for now.

  • Have you ever replaced the hd? Harddrives go downhill over time. I'd run etrecheck. The proprietary stuff gets filtered. It has basic tests for harddrives. -- Download etrecheck. Then click on the download link at the bottom of the screen. etrecheck.com -- Run etrecheck. The first five runs are free. -- Using EtreCheck by etresoft, the author discussions.apple.com/docs/DOC-11591 – historystamp Mar 4 at 4:18
  • i doubt it was the HD itself, otherwise i wonder why its working now. i havent had any such problem for some years and it seemed to coincide with the security update. my hard drive was pretty full at the time of the incident, its possible a memory overflow caused it or if the security update began itself that may have triggered the issue too. i will try the etrecheck though, i recall using that tool for something else at some stage. – jsky Mar 4 at 9:23
  • It's a weird situation. I don't encrypt my hd, because recovery is harder. But everyone's security needs are different. – historystamp Mar 4 at 19:38
  • 1
    Try a safe boot. Shutdown your machine. Hold down the shift key. Poweron. The boot up will take longer than normal because the filesystem on the startup drive is being checked and repaired as needed. All about safe mode including what features and apps safe boot leaves out. Safe boot uses a software driver instead of using your machines video hardware. support.apple.com/kb/ht1455 – historystamp Mar 22 at 2:40
  • 1
    I and many others do not recommend "Might try a maintenance program." These are all scams and many will make your mac worse. Stay with etrecheck and might try malware bytes. – historystamp Mar 25 at 18:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .