I'd like to install homebrew on my iPhone running iOS 10.3.3, which is jailbroken and has Terminal and NewTerm installed.

When I run /usr/bin/ruby -e "$(curl -k -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" I get:

dyld: Library not loaded: /usr/lib/libruby.1.9.1.dylib
Referenced from: /usr/bin/ruby
Reason: no suitable image found. Did find:
/usr/lib/libruby.1.9.1.dylib: can't map segments into 16KB pages
/usr/lib/libruby.1.9.1.dylib: can't map segments into 16KB pages
/usr/lib/libruby.1.9.1.dylib: can't map segments into 16KB pages
/usr/lib/libruby.1.9.1.dylib: can't map segments into 16KB pages
Abort trap: 6

The command that I tried to use is the command that macOS uses to install homebrew.

Is there any way to successfully install homebrew on my iPhone?

This problem could be caused by the fact that my phone is only semi-jailbroken.

Ruby is installed, and my phone is semi-jailbroken (no tweaks, whenever I try to jailbreak with tweaks enabled, it gets stuck springing, respring two times and gets stuck at the same spot both times, and then reboots into regular iOS).

  • iOS is the XNU kernel of Darwin. There’s absolutely no trace of Linus being in on on your iPhone or iPad. – Allan Feb 27 at 23:44
  • Oh, isn't debian Linux though? – Sam Feb 27 at 23:47
  • Yes. There's no Linux in iOS. It's based on Darwin which is based on NEXT, BSD, and Mach. macOS and iOS ≠ Linux – Allan Feb 27 at 23:49
  • Would the commands I'm trying to install work if I manually downloaded and moved them into /usr/bin? – Sam Feb 28 at 0:03
  • Or possibly install homebrew manually? – Sam Feb 28 at 0:11

No, this isn't possible.

Homebrew is designed for use on macOS systems. It is not intended for use on iOS, and the packages it downloads will not run on an iOS system. It cannot compile packages for iOS either, as the Xcode toolchain is not available for iOS.

Attempting to install Homebrew will be futile, and may render your device unusable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .