0

Both my Mission Control and Dock are not working properly.

My Dock does not seem to recognize my mouse moving horizontally along the Dock, ie. magnification does not move and when magnification is turned off, the tooltip does not move.

Mission control opens with a gesture, but hovering over the names of desktops/fullscreen windows does not expand the top bar to show previews like normal, and clicking them does nothing but escape Mission Control.

I have tried restarting and even wiping preferences for dock/mission control using defaults delete com.apple.dock; killall Dock. This did not fix my issue.

If it matters, this issue along with general unresponsiveness had been happening and I reset PRAM and SMC. This fixed the general unresponsiveness and my menu bar, which was also not working, but did not fix this issue.

  • Boot into Safe Mode (hold Shift while booting). Does the issue continue? – Allan Feb 27 at 1:49
  • Have you tried re-installing macOS from the recovery partition? – Sam Feb 27 at 6:23
0

My issue has been fixed. Today, my clicking with my trackpad would not work. After some googling, I found that an my disconnecting my external mouse fixed that issue and my original one! No idea why, but I will be probably be replacing my mouse.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .