1

iOS 11.3, macOS Sierra

At night after about 9PM, my iMac is either asleep or powered off. If during that time I receive any messages to my phone, they will not appear in the Mac message history when I wake it up or turn it on again.

I hate how my different devices (phone, tablet, laptop, desktop) all have different message histories. Generally the phone is the only complete one since it pretty much never turns off.

enter image description here

Is it even possible to get a Mac to fetch recent messages that it missed?

  • What version of macOS are you using? My Mac occasionally gets a little bit behind, but has always caught up eventually. – dwightk Feb 26 at 23:36
  • Are you sure your phone is set up to use iCloud for messages? – Thorbjørn Ravn Andersen Feb 26 at 23:47
  • Question updated to include OS versions. As for "iCloud Messages" there is no such option on my Mac (Sierra). Maybe this was added in High Sierra or later? I see it on my Laptop running High Sierra so I suspect that's the case. – Jonathan van Clute Feb 26 at 23:57
  • It works in El Capitan and newer. As long as you have everything synced with iCloud, the messages will be in sync - they may take a few mins to catch up, but they do. – Allan Feb 27 at 0:06
  • Well since there is no "iCloud Messages" option for Messages on Sierra... this doesn't seem to be the case. And the messages NEVER "catch up". Ever. I can leave my machine on for days or weeks, they will never catch up. – Jonathan van Clute Feb 27 at 0:08

You must log in to answer this question.

Browse other questions tagged .