2

I'm trying to backup my computer for the first time running Yosemite OS. The time machine fails, despite trying with two different external USB 3 drives with this error partway into the Time Machine backup and then giving up on the whole backup:

Time Machine couldn’t complete the backup to “Backup”.

An error occurred while copying files. The problem may be temporary. If the problem persists, use Disk Utility to repair your backup disk.

Using Disk Utility finds no errors to repair.

I tried to manually copy the files in /home/Username to the backup using the finder and it failed partway through on a .dng image of around 30 MB in size, for which I did not capture the full error message.

I then tried to do the folders it had not yet gotten to in the above failure and got a second error:

The operation can’t be completed because an unexpected error occurred (error code -8084).

According to this page, it would be due to a file over 4GB and my partition format not accepting that. However, the disk is partitioned using Mac OS Extended (Journaled). Note the disk itself uses GUID Partition Map.

I'm guessing that the issue is not the USB drive, but something physically wrong with my MacBook Air from early 2011. When I took it to Genius bar, they ran diagnostics and found nothing wrong with computer except need to replace the battery that showed as exhausted. Other problems with Mac are the trackpad does not detect clicks most of the time, but tracks mouse moves and the wireless connection drops often despite a strong signal from the wireless access point.

How can I successfully backup my files? Should I give up on this Mac and buy a replacement? Would like to backup even if I go to a new computer, so looking for a solution to save the disk state.


Carbon Copy reported this error when setting up backup:

macOS is reporting read or write errors on "Macintosh HD"

These errors indicate that there is a problem with this disk, such as media failure, a mechanical failure, an error in the disk's firmware, or a problem communicating with the disk. The severity of the problem is unknown, you can get more detail on the errors by clicking on the affected volume in CCC's sidebar. Read/write error statistics will be reset when you restart your computer.

And then proceeding with backup it gave:

The "CCC Backup Task" task has encountered physical read errors

Physical read errors may cause the backup task to take longer than normal. You can stop the backup task at any time. CCC will pick up where it left off the next time you run this task. Open CCC and click on the source volume in the sidebar for read error statistics.

It shows 20 Read Errors and 0 Write Errors in the sidebar.

Backup is proceeding.

  • The USB-disk for Time Machine must be HFS formatted – Thorbjørn Ravn Andersen Feb 24 at 16:55
  • @ThorbjørnRavnAndersen I believe that HFS+ is another name for Mac OS Extended (Journaled). – WilliamKF Feb 24 at 19:16
  • Yes. Not ntfs/FAT32 – Thorbjørn Ravn Andersen Feb 24 at 19:59
2

I would suggest backing up your files using CCC (Carbon Copy Clone), which makes a bootable duplicate of your drive.

You can get the 30 day trial for CCC here, or here for the a paid version (I always suggest paying the people who made the apps though).

Also, I suggest reinstalling macOS from the recovery partition (reboot using cmd R).

Personally, using the time machine rarely works for me.

  • Carbon Copy Clone succeeded in backing up. Reinstalling MacOS did not fix drive read errors. – WilliamKF Feb 25 at 17:29
  • Sorry, that I can’s help make apple’s backup system work – Sam Feb 25 at 17:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .