I want to modify DefaultFonts.plist for the Notes application. I've tried a few different ways since what worked on old OS doesn't on 10.14 Mojave:

  • I've navigated to the file through finder, went to Get Info, unlocked the file (via the lock icon), and tried to change permissions.

I get the message "The operation can’t be completed because you don’t have the necessary permission."

I've tried this command:

chmod 777 /Applications/Notes.app/Contents/Resources/en.lproj/DefaultFonts.plist

I get the message: Operation note permitted

I've also tried:

sudo nano /Applications/Notes.app/Contents/Resources/en.lproj/DefaultFonts.plist

I'm able to get into the editor, but when I try to save I get message: "error writing /Applications/Notes.app/Contents/Resources/en.lproj/DefaultFonts.plist"

also, I cannot cd to /Applications/Notes.app/Contents/Resources/en.lproj. (And I cannot see Notes.app when I'm in the Applications folder.)

The application is closed while I'm doing all this.

I have admin permissions on my computer. What in the world am I doing wrong here?

UPDATE: I'm now able to edit the file thanks to @bmike. However, changing the font size values in the file doesn't seem to affect the application. I think I have the correct file. (btw, not sure if I should be writing this follow-up here or just in comments...or creating a new post. Feedback welcome.) Created new post to address this: Notes.app reverts back to default font when using bulleted list

  • I would start a new post, just lay out what you really want to do. Change the font to comic sans? Change the size? Something else? This might be an XY problem.
    – bmike
    Feb 24, 2019 at 20:37
  • This is good and should be marked solved. SIP prevents editing the file, we should reward this answer and move on to what’s next, new question style IMO. Just link here in comments so we all can see the next challenge.
    – bmike
    Feb 24, 2019 at 20:38
  • Thanks again, @bmike. I'm posted the question here, which speaks to the problem of Notes reverting back to the default font when you use bulleted list: apple.stackexchange.com/q/352343/196229 Thanks for getting me over the first hump! Feb 24, 2019 at 21:27
  • @grg, thanks for linking to that other question. It's useful. I didn't realize that SIP <strong>was</strong> the issue here until bmike pointed it out. I tried searching for the original problem, "cannot update DefaultFonts.plist" but didn't find an answer. I want to be a good citizen here, so I welcome input if I'm doing something wrong. Feb 24, 2019 at 21:48

1 Answer 1


Several of Apple's bundled applications are protected by SIP (System Integrity Protection). As a result, they cannot be modified, even with root privileges. The -lO flag for ls will show you if a file or folder has restricted status:

ls -lO /Applications/Notes.app/Contents/Resources/en.lproj/DefaultFonts.plist
-rw-r--r--  1 root  wheel  restricted,compressed 538 Aug 20  2018 /Applications/Notes.app/Contents/Resources/en.lproj/DefaultFonts.plist

If you want to proceed, you'll have to disable SIP, make the modifications, and then consider re-enabling SIP. (I strongly recommend not leaving it off, as it provides valuable security for your Mac against malware and other issues like inadvertent destruction of system critical files.)

If you don't like Apple's procedure for disabling SIP, You'll find many webpages explaining how to disable SIP. Here's one.

However, it's possible that altering the app directly may compromise its code-signed status. (Again, a security feature designed to stop apps from running if they've been modified.) You may need to look for another way of changing the font in Notes.

  • thanks, @bmike! That worked. I was able to edit the file. Oddly though however, changing the font size values in that file doesn't seem to have an effect on the applications. My language (System Preferences > Language and Region) is set to English (US), so I think that should be the correct file. Feb 24, 2019 at 19:59
  • Why not actually check the codesigning status of that file? Feb 24, 2019 at 20:22
  • What does Apple Support have to say if you engage them @WillBrooklyn - I’m sure their accessibility team would be interested in the Y you wish to achieve once the X of editing a file is dismissed. Bigger fonts? Different fonts? Something else you’re trying to do?
    – bmike
    Feb 24, 2019 at 20:36
  • Thanks, @bmike. I'll create a new question for this and link to it, as you suggest above. The reason I want to be able to change the default font is this: While you can change the font style and size through the UI, things break down when you use a bulleted list. For whatever reason, the application ignores the font of the rest of the doc when you create a bulleted link, and reverts back to the default font from that point forward. e.g., screencast.com/t/MGYxbjOn1fdQ Feb 24, 2019 at 20:54
  • That’s an amazingly useful case that should be fixed if we can’t find a workaround. Well done documenting it!
    – bmike
    Feb 24, 2019 at 20:56

Not the answer you're looking for? Browse other questions tagged .