Anyone got a good checklist for diagnosing the problem with a dead MacBook Pro ? I've a 15" MacBook Pro Core Two vintage machine that has suddenly stopped booting up. I can hear the Superdrive spin up, but then it stops with a black screen. Doesn't seem to want to boot from either the harddrive or the Superdrive (I've tried a Linux boot CD there).

I'd like to try to figure out if it's a problem with the display, with the logic board or something simple before I decide whether or not to scrap it.

I've tried booting with an external display attached to the displayport and still no joy (black screen). It doesn't ever get to a grey screen, so I flunk out before ever getting to the checklist below. I tried resetting the PRAM just in case, but no joy there either. When I power it down, I don't hear the "CHUNK" from the harddrive, but I've still got a boot CD in the Superdrive (any ideas on how to get THAT back out ?) so maybe it never gets to the HD.

Thanks for any advice. Dane

  • If you push and hold the power button after a failed boot, does it click like it does if you hard reset? That would indicate a screen failure, another way to test this is just to plug a screen into the displayport - it should fire up with boot. If the screen (or backlight) doesn't come on at all that may well be the cause. – George Pearce Jan 2 '12 at 1:06
  • Why not start with support.apple.com/kb/TS2570 and edit your question to point to the step that failed? – bmike Jan 2 '12 at 16:33
  • What led up the failure? Did it shut down normally and fail to boot the next time? Have you changed anything recently - hardware, software updates, drivers, kernel extensions, ...? – JRobert Jan 2 '12 at 18:53
  • I tried to do a memory upgrade, but have replaced the original memory. I was grounded and saw no sparks when doing the upgrade, so I think it should have been safe. – Dane SKow Jan 2 '12 at 22:47
  • 1
    Then the next thing I'd do would be to confirm which memories work or don't. 1) re-try try each pair of memories again but swapping slots; 2) try only 1 stick in the machine at a time (I don't think those memories have to be matched but I'm not sure about that); and 3) try each set of memory in a similar machine. At the end of that you should know whether you have bad memories or a non-memory issue. – JRobert Jan 2 '12 at 23:02

I had the same issue when upgrading my RAM.
It turned out that the SO-DIMMs were not properly inserted.

Try the following:

  1. take out both SO-DIMMs
  2. re-insert the first one and make sure it goes fully into the lower socket
  3. try rebooting
    • if it works, shut down again and insert the second SO-DIMM (again taking care to fully insert it into the upper socket.)

Good luck.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .