0

A few days ago, my iPhone stopped charging from my laptop. I have tried some suggestions and contacted Apple support, but neither was helpful. My phone will charge if it is connected to anything else, just not the computer.

I have had both for a while now so neither is brand new. I know that the lightning cable is functional because my cooling pad, which is connected to it, works. I have tried a few different USB cables and they all seem to be recognized by the device (the USB accessory notification pops up on the lock screen when the device is restarted). However, no cable will charge the phone if power is coming from the computer.

This all began after an odd incident with my phone. While attempting to kill an app, the screen froze. I pushed the power button and tried to unlock my phone again, expecting that the problem would be solved. However, the phone was still locked to the same screen. I was unable to turn off the device so I just let the battery run. My music continued to play and notifications continued to show on the Lock screen and on the unlocked device. When it started back up, it worked fine. The next day, I plugged my phone into my laptop and the laptop experienced a kernel panic. Once the device restarted, my phone charged with the computer and everything was fine. The next day, however, this problem started. I don't know if they're connected, but it seems pretty strange as I've never had either of these problems before.

Luckily, my computer and phone are working fine now (as far as I know) outside of this error.

Does anyone have any ideas?

  • Welcome to Ask Different! Can you make sure USB Restriction is turned off? In Settings, go to Face ID & Passcode or Touch ID & Passcode, and turn on USB Accessories under Allow Access When Locked. Does that help? – fsb Feb 22 at 23:02
  • This did not work. I have tried to charge another iPhone with the laptop since I originally made this post and that did not work either so the problem has to be with the MacBook. – LostInTerminal Feb 22 at 23:26

You must log in to answer this question.

Browse other questions tagged .