0

My Time Machine backup drive became corrupt. It would take several minutes to mount, and then MacOS would warn me to back up the data. When I tried copying Backups.backupdb out I got "Error Code -36" saying that some data couldn't be read or written.

I was able to copy a few (apparently non-corrupt) individual backups out using finder, but unfortunately Apple has removed a multitude of admin permissions, including the ability to change Backups.backupdb, so I'm unable to copy my backups into it. Access denied (even with SIP disabled). We're also not not allowed to modify folder permissions, FWIW.

Any ideas on how to transfer individual backups into Backups.backupdb?

  • What exactly are you trying to accomplish here? Did you try to restore through the Time Machine interface and it failed? Do you try to restore with Terminal commands? What exactly are you trying to combine here, data from several subfolders (backup dates) within Backups.backupdb? Please give some more details about what you've tried (ideally with specific error messages, copy/page from Terminal, or pictures) and where it failed. Right now there is too much guesswork involved in trying to answer this. – nohillside Feb 22 at 6:02
  • Sorry about the confusion. I hope my edit helps. Even with my poor wording I think I found a solution. I think the technical term is a "ridiculous hack", but it works. – Change Machine Feb 22 at 20:20
  • So basically you want to put data back into your backup history, right? Why would you even do that if the backup as a whole seems to be corrupted? And wouldn‘t it be simpler to just run a full TM backup onto a new disk? – nohillside Feb 22 at 20:34
  • Long story: I bought a new MBP, set it up, installed fresh OS, ran backups, the MBP failed and I sent it back. I ASSumed it'd be quick and painless to just use Migration Assistant to clone that to my new MBP, but what used to be simple drag-and-drop, Apple has turned into a challenge. And I solved it, so I WIN, APPLE! >:0 – Change Machine Feb 22 at 20:42
  • I also installed and licensed lots of apps, tweaked settings to my liking, moved my files over... you know how fresh installs are. I wanted to save a little time. Lose. :( – Change Machine Feb 22 at 20:49
1

I think I've found a workaround (or "ridiculous hack", if you will). You can't modify Backups.backupdb, but you can delete it and replace it (back up your backups, if you feel the need):

  1. Create a folder named "WhosTheBoss"
  2. Copy any backups you want to keep in there (same directory structure)
  3. Delete the original Backups.backupsdb folder
  4. Rename "WhosTheBoss" to "Backups.backupsdb"
  5. Point Time Machine and/or Migration Assistant to that location and win.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .