This is related to this other question Prevent MacBook Pro from turning on by touching trackpad.

My new MacBook Pro (MBP) seems to fails to actually shutdown when clicking "Shutdown..." in the "apple" menu.

When I click on "Shutdown..." in the "apple" menu, the laptop behaves as if it was going to sleep rather than fully shut down. It looks as if it does actually turn off (turns black). But then a simple touch on the trackpad or a hit on any of the keys "wakes it up", as if it had been turned off and was powering on again (it goes through the black background screen with the white apple in the middle and the progress bar).

In contrast, if I force shut it down using the touch id button, then the MBP behaved as expected, i.e., it would only turn back on using the touch id button again, and would not turn back on by a simple touch on the trackpad or by pressing a key on the keyboard.

EDIT: after a couple more tries, it appears I was mistaken, in the sense that even force shutting down the latpop does not actually solve the problem (see the discussion in the comments to Monomeeth's answer below)

This unfortunately has nothing to do with how long I wait between clicking "Shutdown..." and pressing a key or the trackpad: This has happened many time after waiting the whole night between clicking "Shutdown..." and pressing on the trackpad. In fact, I have clicked "Shutdown..." many times in the last month without ever having to press the touch id to power my laptop on: I always simply pressed on the trackpad, which made me believe this was the new normal with MBP and triggered my asking of the other related question.

Note also that I never get an error message of the type: "Application X prevented your laptop from shutting down" after clicking "Shutdown...".

I am obviously not fond of having a "Shutdown..." button that does not workperly pro and having to force shut down my laptop every time I want it to actually turn off.

My questions are:

  • Is that a normal behavior for a new MBP? Anyone ever faced something similar? Are there any known instances of a new MBP not actually shutting down when clicking "Shutdown..." in the "apple" menu?

  • What might be causing it? Could it have anything to do with peculiar "Energy saving" settings? Or could it have something to do with an app that would be preventing the laptop from actually turning off without triggering an error message?

EDIT: I have checked on my wife's new MBP, and it behaves in exactly the same way. Is that really a new feature of the latest generation of MBP?

  • 2
    This article might be useful: support.apple.com/en-us/HT202824 (also this one, but it doesn't say much you haven't: support.apple.com/en-us/HT201150#turnoff )
    – dwightk
    Feb 24, 2019 at 15:35
  • 1
    @Martin Van Der Linden, have you ever found a solution for this problem? I am having exactly the same issue on my 16inch MBP. Resetting the SMC, PRAM, booting in target mode, and even formatting the disk and reinstalling Catalina didn’t solve it. Any ideas? Aug 15, 2020 at 15:48

4 Answers 4


According to Apple this is expected behavior on the newest SSD MacBook Pros (mine is an all SSD 2Tb 2018 model, 2.9 GHz Intel Core i9), so don't fight it. By according to Apple I mean during an Apple Care call I had with them where they eventually put a Senior Tech on the line who explained all this and the below to me.

The only "behavior" you may change is to disable the "any key restarts the MBP," such that only the power button is able to restart the machine. It is because any key restarts the MBP that you are thinking that it must be returning from sleep; according to Apple, these new SSD MBPs are so fast on the boot that there is no chime they just goes straight back to login screen (if you have a PW protection or encryption enabled), or to the boot up process otherwise.

But if you observe closely it is not simply going right back to the Finder screen - hitting any key is taking the machine through the startup process, just it happens so fast that it seems like a wake up from sleep.

Anyway you are wasting your time with all of the above the new SSD MBPs will continue to behave like this, and in fact the Sudo / Terminal proposed solution might delete something important and cause issues.


I'd start with resetting both the NVRAM and SMC (in that order). Before following the steps below, ensure you have no external hardware connected and that you're using the built-in keyboard.

Reset the NVRAM

Reset the NVRAM on your MBP as follows:

  1. Fully shut down your MBP.
  2. Press the power button and then press the commandoptionPR keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down for about 20 seconds or until you see the Apple logo
  4. Let go of the keys and let your MBP reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Reset the SMC

  1. Fully shut down your MBP.
  2. Press and hold the power button for at least 10 seconds
  3. Let go of the power button and wait 5 seconds
  4. Power up your MBP again

Once you've reset the NVRAM and SMC use your MBP as usual and see how it behaves when you shut down etc. If it's still misbehaving, reset the SMC again but with the following steps instead:

  1. Fully shut down your MBP.
  2. Press and hold the right shift key and the left option and control keys for 7 seconds before then also pressing and holding the power button down for another 7 seconds (i.e. the keys will end up being held down for 14 seconds, the power button for 7 seconds)
  3. Let go of all three keys and the power button
  4. Wait 5 seconds
  5. Power up your MBP again

If all of the above doesn't work, it may be worth testing your MBP in Safe Mode to see if it behaves differently to how it does normally.

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your MBP.
  2. Restart your MBP
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. does your display wake up normally, etc)
  6. Exit Safe Mode by restarting your MBP as normal
  7. Test again when booted normally

If the problem doesn't occur while booted into Safe Mode, let me know and we'll go from there.

  • Thanks a lot for all the advice. I've tried to follow it, so far to no avail. Before detailing what I've tried, I would want to make sure I did things right so far. Is there any way for me to make sure 100% that I actually reset my NVRAM and SMC? Feb 25, 2019 at 3:15
  • 1
    Hmm, it's always been one of my bug bears that Apple hasn't implemented a confirmation message for these resets. In terms of the NVRAM, if it's been reset it's possible that some of your settings may have changed (e.g. sound volume). If it has, then it's definitely been reset. If it hasn't, it doesn't necessarily mean it hasn't been reset. Personally I will normally go through the NVRAM reset process a couple of times for good measure (this does no harm). You could deliberately set the volume really low and then do the reset to see if it changes - just so you know what your volume was before.
    – Monomeeth
    Feb 25, 2019 at 3:30
  • 1
    As for resetting the SMC, this is even harder to confirm. If you're still having your shutdown problem, use the 2nd process for resetting the SMC. If you still have the problem, then also test your MBP in Safe Mode and let me know what happens. Remember though, when doing these resets use the internal keyboard not an external keyboard.
    – Monomeeth
    Feb 25, 2019 at 3:30
  • Thanks for following up. I have been using the built in keyboard. One of my problems is that using the keyboard is precisely what... well... triggers my laptop to start up, which may interfere with the attempt to reset NVRAM and SMC's as I understand it. (I thought force stopping my laptop using the "touch id" button actually shut it down and prevented it from restarting through pressing keys, but after some more tries, I am not so sure anymore.) I will try a couple more times as you suggested, and I'll let you know. Thanks again for all your help. Feb 25, 2019 at 3:39
  • 1
    I believe my issue is I am unable to "Fully shut down my MBP" in the first place, which suggest I have no chance of actually resetting either the NVRAM or SMC in the way you suggested. I initially thought force shutting it down with the "touch id" button was doing it. But after a couple more tries, it appears it doesn't: Even when force shutting down through the "touch id", my laptop still doesn't really shut down, and wakes up with a simple touch of the trackpad or a press on the keyboard. Feb 25, 2019 at 3:43

I had this problem with my 13" MBP 2011 model MacOS High Sierra, and the following commands in the Terminal resolved it.

You may need Admin access when prompted,

sudo rm -f /Library/Preferences/com.apple.loginwindow.plist
sudo rm -f /private/var/db/.AppleUpgrade
sudo rm -f /private/var/db/.SoftwareUpdateAtLogout
sudo reboot

I even reinstalled macOS High Sierra before trying out the above solution but that did not work.

Source: Black Screen With Cursor on Logout in Yosemite

  • Yup, all the other answers and even a repair installation failed to fix this for me but Santhankrishnan's solution fixed it! Jun 30, 2021 at 20:44
  1. This is not normal behaviour, and unfortunately yes
  2. No, I don't think anything like that is causing it

It seems to be a semi-common problem in new computers, :/ thanks apple.

I just remembered a bit of a weird way to fix this:

  1. Go to system preferences -> startup drive
  2. Push restart into target mode
  3. Restart (using the power button)

That should fix it. I don't know why this works, only that it does.

  • Thanks for the tip. Unfortunately did no work for me: after restarting in "target mode", I got stuck on a black background screen with a pair of large white USB and Thurderbolt signs moving around (as well as a green battery indicator that did not move). I forced restart from there, and everything was back to normal, including my shutdown problem. One guess: if for others the problem has had anything to do with the target mode, maybe its related to apple systems that have been "cloned" from another system (as is the case of my system, as well as my wife's). Feb 24, 2019 at 20:11
  • Yes, that is what target mode does. I've found that new macbook pros (the ones that I've worked with at least) that have shutting down problems can had their problem fixed by this. Sorry that it didn't help you though :/
    – Sam
    Feb 24, 2019 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .