1

No matter what I do, I cannot get a web site to load after something changes with the DNS.

For instance, if meh.blah.example.com had a misconfigured DNS value and produced an ERR_NAME_NOT_RESOLVED then fixing the DNS issue would work on everyone else's computer in the office within minutes of making the change, but on mine it is stuck forever. Days can go by and I'm effectively locked out of meh.blah.example.com. This is making performing dev-ops a major headache.

I've tried clearing it at the system level:

sudo dscacheutil -flushcache
sudo killall -HUP mDNSResponder

I've tried clearing it in Chrome:

enter image description here

I've tried emptying the cache with a hard reload:

enter image description here

Pinging the domain:

ping: cannot resolve meh.blah.example.com: Unknown host

I've tried restarting my laptop.

Tried adding the Google DNS servers to my list:

enter image description here

Tried restarting DNSMasq:

brew services restart dnsmasq

Tried turning off Chrome's prediction service.

Trying on Safari doesn't fix the issue.

If I run nslookup meh.blah.example.com 8.8.8.8 then Google confirms they can find it thru their DNS servers.

Is it possible some service is running on my Mac I can't see that is caching things?

  • 1
    Why have you got the first dns entry beginning with 127? – Mark Feb 22 at 0:11
  • That is dnsmasq – ShrewdSimian Mar 1 at 3:20
  • Do you have the problem without dnsmasq? – Mark Mar 1 at 7:49
  • Yep. Tried stopping the service, but no luck. – ShrewdSimian Mar 2 at 21:36

You must log in to answer this question.

Browse other questions tagged .