18

I haven't been interacting with Mail for half an hour, but suddenly it opens its main window in split screen with the fullscreen video player that I'm watching. This happens every other day.

I can't really say if this only happens when Mail is running, since it's hard to check that after the fact. Assuming it only happens when Mail is running, can something be done other than making the habit of always quitting Mail as soon as possible? Is there some hidden feature triggering this?

9

I've been having the exact same problem for a while - particularly interesting while I'm trying to watch netflix!

I found a checkbox option in the Mail->Preferences tab which says "Prefer opening messages in split view when in full screen" (see screenshot). I've unchecked that so here's hoping it solves the problem!

If it doesn't, I've seen a few other posts about this suggesting that the fact that it pops up at all is something to do with Google Calendar if you have any Google accounts assigned to your mailboxes. See if this link helps you if so!

.

Screenshot

| improve this answer | |
  • 19
    The option doesn't work for me unfortunately. – oarfish May 28 '19 at 13:59
  • 2
    the problem with this answer is that in the non full screen view, mail window pops up above other apps. Although question asks only for split view, but one should go for the overall solution. – anki Jun 4 '19 at 17:44
  • Look at the duplicate discussion. The culprit seems to be Google Cal notifications, which can be deactivated on several ways (online, or another way of account setup). – leon Nov 4 '19 at 0:12
  • 1
    Unfortunately, despite being highly upvoted, this answer doesn’t solve the problem at all, and the option in the suggested fix is unrelated. – Konrad Rudolph Feb 20 at 11:38

Not the answer you're looking for? Browse other questions tagged .