Got this error:

The item XYZ can't be moved to the Trash because it can't be deleted.

Never seen this before. How to I enable it to be deleted?

enter image description here

File is stored on an SD card.

Checked permissions. Says: You can only read

Which I have also never seen.

Tried touch /Volumes/<Name of SD Card> and got the response: touch: /Volumes/<Name of SD Card>: Read-only file system

enter image description here

  • what format is the sd card? – Sam Feb 21 '19 at 2:03
  • Is the SD card write protected? Test it out by issuing the command touch /Volumes/<Name of SD Card> Let us know what happens – Allan Feb 21 '19 at 2:14
  • @Sam format is ExFAT – Joshua Dance Feb 21 '19 at 2:42
  • @Allan response touch: /Volumes/1: Read-only file system Which is weird because it is ExFAT which I thought was Read Write. – Joshua Dance Feb 21 '19 at 2:43
  • 1
    Back up the SD card (copy contents to a folder on your Desktop) then wipe the SD card. If you can't then the issue is the SD card. – Allan Feb 21 '19 at 2:50

Found the issue. The Lock Switch was set to Lock. 😕

A client had sent me the SD card with video files. I didn't even think to check the lock switch when I loaded it up.

So flipping that to unlock, and it fixed the error and the permissions.

enter image description here

| improve this answer | |

Unlock permissions, change your permissions to read/write. If you can't do this, then that means that it's a format that macOS can only read, and not write to.

| improve this answer | |
  • 1
    The format doesn't determine if you can read or write. Write protection and file permissions do that. – Allan Feb 21 '19 at 2:20
  • I can't seem to access the permissions to unlock it. Tried Get Info, all the usual methods. – Joshua Dance Feb 21 '19 at 2:42
  • 1
    Are you admin?. – Sam Feb 21 '19 at 2:43
  • 1
    @Allan macOS doesn't come with read/right abilities for all formats – Sam Feb 21 '19 at 2:44
  • 1
    Don't worry about it, we all make mistakes sometimes – Sam Feb 21 '19 at 4:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .