18

Today, I came back from having a coffee, unlock my Macbook (12" 2017, running Skype version 8.39.0.175 in Mojave 10.14.3 and I see this:

screenshot

Does anyone have any idea what is this and why would Skype want to export it? I haven't even restarted it, unless it autoupdated and restarted itself

Update: I allowed it eventually and nothing happened as far as I can see, all the keys are still where they are supposed to be, contrary to some comments.

  • I saw that yesterday - for the first time. I just said 'Deny' about 10 times until it finally went away. Finding an explanation would be good. – Tetsujin Feb 21 at 8:49
  • could you please go to keychain access app and see all the keys present in the "keys" section under "security"? see what kind of keys are there and info about this one too. – ankiiiiiii Feb 22 at 19:53
  • discussions.apple.com/thread/7081399 fixed my issue – Stanislau Buzunko Feb 22 at 21:16
  • no, it didnt. after restart the issue it still here – Stanislau Buzunko Feb 23 at 7:30
  • 3
    I dismissed it many times, but finally I hit accidentally the allow button. It deleted all the passwords in my keychain. Please everybody be warned. Macbook just got back from time machine recovery – maggocnx Feb 24 at 7:47
3

I seem to have fixed this... unfortunately I don't know what part of what I tried was the actual key to the fix.

I spoke to Skype support, live chat. They hadn't heard of the issue - though tbh, 1st line support are always going to be 'last to know'.
The best I could get was 'Have you tried reinstalling it?" I said, it's a Mac, reinstalling isn't going to make any difference.
We tried it - it didn't. No surprise there.
I did it again, this time using CleanMyMac to get all the prefs & hidden stuff, kexts etc; rebooted & tried again. It still remembered my login details so I'm not sure how successful that was.

I looked in keychain to see what was in there. I was surprised at how many bits & pieces there were.
Having made sure I knew my login details, I deleted the whole lot; everything that came up when I searched 'skype' - maybe 10 or 12 keys - & rebooted again.
Skype had lost my auto-login... good.
I could then see which new keys it added as I completed a manual login.
There were only two keys - Skype for Desktop & Skype for Desktop MSA. After several days there are still only two.
No functionality seems to have been lost. Conversation histories etc appear to be stored at Skype, not on the local Mac.

It hasn't asked me to export anything since.

It would probably be useful if someone else with this issue could try deleting only the Keychain entries, or only doing the 'clean' reinstall; reboot & see how that goes. See if we can figure whether it's the 'clean' reinstall or the keychain deletion that actually fixes it.

Note: This machine has a complete line-of-sight migration path back to my first OS X Mac in 2005 & some data from before that, when I migrated from OS 9. Skype has been on it since it was invented, so I may have a whole lot more historic cruft than most people.

  • I had the same problem on High Sierra, and always clicked "Deny access", Skype was still working. After a few reboots and updating Skype to latest version the problem disappeared. It might have been a generic Keychain problem, as also the app Sourcetree was having some keychain problems. During the last days I also updated to the latest High Sierra MacOS patches. Anyway one of these things fixed it, problem is gone for a few days now. I did not manually edit the Keychain at all. – kasimir Mar 3 at 12:47
  • 1
    My Skype has also updated since this answer. We may never know quite what it was. This question generated a lot of interest over a few days, but since has gone very quiet - maybe it did 'fix itself' in an update, so people have lost interest. – Tetsujin Mar 3 at 12:56
0

I found this. I hope it works, but I'll have to wait and see because I only see the Skype-message every three or four days. https://discussions.apple.com/thread/7081399

  • 3
    Answers should be more than just a link. Please include the relevant parts directly into your post so it stands on its own, and keep the link for reference. – nohillside Feb 24 at 8:00
-2

Try to reinstall the Skype. It helps me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .