0

There are two usecases for my MacBookPro15,1: When I am on the road I just use it as it is without any peripheral devices. But when I am at home, I put it (with closed lid) in the book arc and connect it to my thunderbolt3-dock (Kensington SD5000T). The dock is connected to ethernet, two displays (via TB3-to-2x-DP Adapter) and my USB-Audio-Interface (RME Fireface UC). Additionally I use a Bluetooth Kebyboard and a BT-Trackpad.

Everything works fine except the audio interface. That only works after reconnect.

I suspect some security feature of the OS that ignores all formerly unconnected USB-Devices before login. But I am not sure about this.

Its getting on my nerves to reconnect the audio interface every single time. So I want my macbook to recognize this device automatically. Maybe its possible to rescan USB after login or mark this audio interface as trusted device somehow?


UPDATE

As jksoegaard suggested, I tested whether the USB recognition problem is related to the TB3-Dock. It is not. Here is how to reproduce:

  1. Have the open MacBook on the desk with nothing connected.
  2. Make sure its locked
  3. Plug in a USB device, for example a microSD Cardreader with card in it.
  4. Wake up and unlock the macbook (password, TouchID, Applewatch,...)
  5. Notice: The plugged-in USB-Device is not recognized at all (not even unmounted as onik suggested in his comment)
  6. Disconnect and reconnect the USB-Device
  7. Notice: Device is recognized correctly

As I remember correctly, I already know this behavior from my old MBP (early 2013), since I bought it back then.

For the sake of completeness, I also tested this behavior with my MBP from work (Generation 2018, 13" Touchbar). It is exactly the same there.


UPDATE 2

jksoegaard pointed out that my last update was confusing because I used a USB cardreader for testing instead of the audio interface. For clarification: the cardreader was meant to be a generic usb device (which is not the audio interface) for testing. But as it seems, storage devices are something different.

As I tried out to connect the interface to the macbook directly, the problem got weird. There seem to be two cases.

First:

  1. switch audio interface off
  2. connect to macbook (does not matter if locked or not)
  3. switch on audio interface
  4. audio interface is recognized correctly

Second:

  1. Audio interface is switched on and was last used in via the TB3-Dock connect audio-interface directly to macbook (does not matter if locked or not)
  2. audio interface is not recognized
  3. Disconnect and reconnect audio interface (does not matter what port or how often I try)
  4. audio interface is still not recognized

That makes the audio interface look like the root cause of the problem. But I do not understand why it behaves completely different on the TB3-Dock. If connected via the dock, there is no interface power cycle needed, because reconnecting works at the latest.

This leaves me a little puzzled, as i do not know how to pin down the problem further. Any advice?

  • The same thing happens sometimes with my USB-C dock and my external USB HDD. It's connected but not mounted when I plug in the dock, I have to mount it manually or replug the drive. I'll check if it's determined by whether the laptop is locked or not tomorrow! – onik Feb 20 at 14:51
  • @user406482 Your update seems to confuse the matters a lot. Now you're talking about a disk being mounted or not, which is entirely different from a USB device being recognized or not. Your first version of the question was about an audio interface not being recognized. Is this problem only about mounting disks, or is it generic for all USB devices including the audio interface? – jksoegaard Feb 21 at 7:55
1

To my knowledge, there's no such security feature in macOS.

On my system I can easily connect the MacBook Pro with a closed lid to my dock (OWC Dock) and USB devices automatically reconnect.

I would test if this happens with all USB devices, or just with the audio interface.

In case it is generic, contact Kensington support to report the problem. I have checked their web site, and it seems they have no firmware updates or the like available for the product.

In case it is specific to the audio device, contact RME to report the problem, and check if they have firmware updates, driver updates or similar available.

  • Thanks, I tried what you said. But unfortunately the result is unrelated to the dock or the audio interface. I updated my initial post accordingly. – user406482 Feb 20 at 21:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .