3

Just recently, I notice that while using my mac terminal I can't type in the '%' character.

I can use any other character using the same key, for example '5' and '∞' (option+5), but when I want to use '%' (shift+5) I get the error terminal sound.

If I try to copy and paste text with a '%' included, it will copy all the text except for the '%'. If I connect to a server using ssh, ‘%’ works perfectly.

Any suggestions to fix this?

  • 1
    Welcome to Ask Different :) Try running stty sane. – Nimesh Neema Feb 20 at 7:59
  • Hi @NimeshNeema. Thanks for the replay. I tried stty sane, but it didn't work. – Raymundo Feb 20 at 8:30
  • 1
    Have you edited any of your configuration files? – Thorbjørn Ravn Andersen Feb 20 at 8:58
  • @ThorbjørnRavnAndersen not really. I've only worked in .bash_profile. – Raymundo Feb 20 at 9:14
  • 1
    Might be it. Show us all the changes you’ve made. – Thorbjørn Ravn Andersen Feb 20 at 9:51
3

The problem was in the .inputrc file in my home directory. The first line of this file was like this:

% Cnd down arrows cycle through commands that match the start of a line

I had to changed the '%' at the beginning for a '#'. Still I don't know why that line had the percentage instead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .