1

Spotlight search not searching including Applications in the result MacOS Mojave

Problem: apps not being included in the result. None of the apps show up. Expected behavior: FaceTime App included a top hit.

  • Tried re-indexing by adding and then removing from Privacy tab in spotlight settings. No change.

  • Rebooted multiple times. No change.

followed the suggestions in this two links as well. No change.

Spotlight search stopped suggesting my frequently-used app

Single application not showing up in Spotlight

Sys info :

enter image description here

0

I am running several test Mojave (10.14.3) macs in my work environment before I am deploying it to our macs.

I do not seem to have a similar issue, as can be seen with these screenshots: enter image description here enter image description here enter image description here enter image description here

How did you install Mojave? A fresh clean install? Or was it updated from HFS/APFS High Sierra?

What happens when you run the program, close it, and then try to spotlight the app? Does it show then?

I found this, not sure if this was tested with Mojave but might point you to right direction: Applications Don't Show Up in Spotlight

  • 1
    It's not a fresh install. I have been updating to the most available release every time it became available. I never had an issue with spotlight search before, I started having the issue with apps first and now nothing other than my browsing history and notes (from the Notes app) gets indexed. – Amanuel Goshu Feb 21 at 5:58
  • I followed the link you attached and it showed me how to disable and re-enable indexing using the modutil command and that fixed my problem. Thank you! – Amanuel Goshu Feb 21 at 6:06
  • No Problem glad that helped! – chrisdahfuh Feb 21 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .