I have an iPhone 3G, whenever I add a photo into a folder in iTunes, and then I sync it to my iPhone, the photo doesn't appear at all in the folder on my iPhone.

Why is it doing this? The image is JPEG image type.

  • 2
    You're adding photos to a folder in iTunes? Are you adding them to iPhoto, then selecting them in iTunes? – ghoppe Oct 27 '10 at 23:54

There could be any number of issues here; not enough room on the device, corrupt image(s), adding photos in the wrong place... Since I can't know what your exact issue is without more details, I will offer up a suggestion for a "flow" that works for me.

  1. I sync photos from various cameras (including iPhones) to iPhoto
  2. In iPhoto, I have setup a Smart Folder that has at least a Date filter of Last X Months where X is something you can specify depending on how far back in time you want to sync over to your iPhone

iPhoto Smart Folder Setup

Once it is setup, iPhoto will show you the photos that match that filter

Last 3 Months of photos in iPhoto

  1. Finally, in iTunes, you will connect your iPhone, select it in the iTunes window and using the tab bar at the top, select Photos. Turn on Sync Photos from iPhoto, select Selected albums, events and faces, and automatically include no events (note: include whatever events you want there, I include none). Then scroll down in the Albums list until you see the Smart Folder that you created in iPhoto and put a checkmark next to it.

iTunes iPhoto sync

Then the next time you sync your iPhone with iTunes, it should sync over all the photos in that Smart Folder. If it is too many, you can reduce the time frame that you pull photos from or use tags in iPhoto to mark some pictures to exclude and then include that information in your Smart Folder setup (telling that folder to exclude those tags).

If this is not the kind of information that helps you, then post some more info about the issues you are having so we can try to answer those specific issues directly.

Good luck!

You must log in to answer this question.