2

Apple ID sign-in is not working from Linux OS browser (Chrome, Firefox...tried both with new session cookies cleared, and incognito). I can browse apple.com without issues. I needed to check Apple ID after getting what appears to be a bogus security alert on my iPhone about a FaceTime sign-in on my table.

I've tried to login to Apple ID page from 3 different public IP addresses (cities) and Linux based desktop & laptop computers with latest updates. Login works fine from a Windows computer.

I spoke with Apple Support and they said:

we are only trained on Apple products so we are unable to help you with that.

When they said they could escalate it to one of the engineering teams and get back to me, I offered to give the Chrome and Firefox versions along with the OS information and again I was told:

we are only trained on Apple products. That information will not likely be useful to our team.

I can't imagine telling one of my customers that when questioned about a cross-platform compatible product/service I provide. It's specifically a bad gateway reported by Apple server and only happens when trying to connect from a Linux computer.

enter image description here

This has never been a problem for me in the past. I figure since the error is reported directly from Apple servers, they made a change in their firewall. I'm not sure what else to try with Apple Support. How do you resolve this?

  • Related: apple.stackexchange.com/questions/351346/… (which originally was posted on AD and then migrated) – nohillside Feb 18 at 15:34
  • @nohillside If that original question was off-topic for this site, why is this question on-topic (and not migrated out)? Is it just because it hasn't been flagged as off-topic yet? – fsb Feb 18 at 16:23
  • @fsb Primarily because the question here has an "Apple Support" angle which the other lacked. But with hindsight maybe the migration wasn't really necessary. – nohillside Feb 18 at 17:35
  • @nohillside TBH, i'm not questioning the migration, I was just wondering for my own education so I would know better how to handle similar questions. Thanks. – fsb Feb 18 at 18:07
  • 1
    @fsb You're welcome. If the handling of these two questions has any educational value it's primarily that flagging and closing is not a very exact science :-) – nohillside Feb 18 at 18:49
2

The response from this user post in a related question was helpful. Specifically, apple is blocking the default user-agent string from Chrome and Firefox on Linux (at least Ubuntu based) computers. To confirm this, I did the following.

Change useragent on Chrome:

  1. CTRL + SHIFT + I to open Chrome developer tools.
  2. Click the 3 dots in the bottom right of Chrome developer tools: enter image description here
  3. Go to More tools > Network conditions
  4. Scroll down to User agent and un-check Select automatically
  5. Enter the following string Mozilla/5.0 (Macintosh; U; PPC Mac OS X; fi-fi) AppleWebKit/420+ (KHTML, like Gecko) Safari/419.3
  6. Enter the following in your browser https://appleid.apple.com

Change useragent on Firefox:

  1. Enter about:config in the URL field and press enter (and accept risk warning).
  2. Enter useragent and press enter.
  3. Look for general.useragent.override

    • If you see it, right click it and select Modify and go to step 4.
    • If you don't see it, right click in empty area of page and choose New > String and then enter general.useragent.override as name and go to step 4.
  4. Enter Mozilla/5.0 (Macintosh; U; PPC Mac OS X; fi-fi) AppleWebKit/420+ (KHTML, like Gecko) Safari/419.3 as value
  5. Enter the following in your browser https://appleid.apple.com

Another way to test this in Chrome in Linux is follow steps 1-4 for Chrome useragent change. Next, instead of entering the example string above, select another useragent (Safari - Mac, Chrome - Mac, Chrome - Windows, etc) from the list. All those useragent's allow access to https://appleid.apple.com from Linux.

Chrome on Windows 10 doesn't have a Linux option to choose from, so to test this from Windows, you can enter one of the following strings I pulled from a Linux machine with the latest updates:

Chrome/Linux
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.109 Safari/537.36

Firefox/Linux
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

In my test this morning from a Windows 10 computer, using those useragent's in Chrome, attempts to https://appleid.apple.com resulted in a 502 bad Gateway. That same test should work from a Mac but I don't have mine with me.

Test from Windows 10: enter image description here

Some information about browser detection.

  • That does not show that there is an issue with the string To show that you need to put a string of a Linux browser in the sender information of safari. – Mark Feb 18 at 21:09
  • 2
    @Mark Safari is not a browser listed with as a problem in this issue. This issue is for Linux users trying to access apple-id from a Browser on a Linux machine (not Mac/Unix). To show there is an issue with the string, you just visit the page from one of those browsers on a Linux machine with the default string intact (Default setup) and see the problem, then modify the string and see access working. – learnsomemore Feb 18 at 21:19
  • What the F?! I would love to get some additional confirmation (from more people) that this is indeed caused by the user agent string. – Wowfunhappy Feb 19 at 4:41
  • @Wowfunhappy if you are really interested, follow the test I added for Windows, or spin up a vm of Linux Mint 19 for example and verify it yourself. Firewall rules and software are continually changing, and apple users don't frequently need to login to apple-id from something other than a MAC. By the time "more people" try to confirm this, firewall, Nginx configurations and browser versions are likely to be different and the problem no longer exist. – learnsomemore Feb 19 at 14:49
1

The best way would be simply to follow the instructions you were given by Apple Support - namely to let them escalate the issue to engineering. Engineering will then likely ask you for Chrome/Firefox versions if that is at all relevant to the problem - right now it doesn't seem likely that the versions numbers have are important.

Usually these errors are an intermittent issue. I.e. an outage that is typically fixed in a short while. It could also be triggered by something in your system, so you might try for example clearing cookies and reloading the page.

It is not a general issue with using Linux browsers to connect with apple.com. Many do that every day without problems. It might be specific to appleid.apple.com - you could confirm that by trying to load www.apple.com. If so you can use the user-agent feature of your browser to hide the fact that you're using a specific browser on a specific OS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .