1

Hi I have a MacBook Pro (15-inch, Mid 2012) that won't boot using any method.

Around 6 months ago, the mac started making loud scratching sounds, but they stopped after a day or so. However, a few days later the mac suddenly froze and then shut down automatically. When attempting to boot, it would reach the Apple logo and fill the progress bar half-way before restarting. This would happen several times in a row before it would finally boot. Then the computer would function normally for a while before the whole process (but no sound this time) would happen again.

When it did turn off, the screen would sometimes fill with rainbow colored bands and any sounds playing would get stuck with one note playing over and over, sounding like a stuck vinyl record. Then when it would get to the half-way loaded point, it would suddenly shut down and restart. It would take luck to finally get to the password screen.

I wiped the hard drive and this solved the problem for a few months. No issues at all. But then back in December it started having the same problems (again, no more sound, just the sudden shut downs and difficulty booting). I was set to wipe the disk again, but this time it refused to boot entirely, no matter how many times I tried restarting and waiting.

It's been a few months since then and nothing has changed. I bought an external hard drive and a USB flash drive in an attempt to boot from a different source than the internal drive. Here is what I have tried and what the results are:

  1. Reset the NVRAM and SMC. Successfully reset, but had no effect.
  2. Try to use Recovery Mode and Internet Recovery Mode. The spinning globe appears, asks me to enter the wi-fi password, then the progress bar completes. The globe goes away and then the screen remains gray but hangs there indefinitely. The options for Disk Utility, Reinstall OS, etc never appear.
  3. Install OS X Lion from a different Mac on to external hard drive and attempt to boot from there. The Apple logo appears, the progress bar fills up half-way, then the screen turns black, before it turns blank gray. It hangs there indefinitely.
  4. Download OS X El Capitan installer on USB drive and use terminal to run createinstallmedia and attempt to go into recovery from there. Same result as above. Currently staring at the blank gray screen as I type this.
  5. Boot from Recovery HD. Same result as above.
  6. Boot as a Guest User in Safari-Only Mode. Same result as above.
  7. Launch into Safe Mode. No error messages found.
  8. Run Apple Hardware Test. I ran the extensive test, but no issues were found with the hardware.

So I've tried all of these methods and I can't even get to Disk Utility or any other options. I don't care if I lose all the data on the old hard drive, I just want to be able to boot from the external drives or at least get to the point where I can run Disk Utility. What could be wrong with the computer?

TL;DR : MacBook Pro 2012 can't boot into recovery from internet, USB drive, or external hard drive. Gets to Apple logo and then either shuts down or hangs on a blank gray screen indefinitely. Help!!!

Other Info: I don't have TimeMachine backups. All the methods I've listed work on the second mac so I'm not entering any commands wrong. When charging my iPhone, if I attempt to boot from the internal drive, the phone will stop charging for a few seconds as the progress bar fills up before resuming charging.

Thank you for any help you may have. It is really appreciated.

1

I would add this as a comment, but I don’t have enough reputation...

Did you use cmd+R for internet recovery?

The reason I ask is that I’m currently going through a similar problem with my 2011 MacBook Pro. My bootable USB installer failed when attempting a clean install. I tried internet recovery using cmd+R, but that failed too.

By using the advice in this post by boris42 to use cmd+opt+R, I was able to enter internet recovery mode and I am currently installing Lion (the only option available), and will upgrade further from there.

  • Thanks for the reply. When I use cmd+R it automatically goes into internet recovery. Using cmd+opt+R I get to internet recovery also. Both lead to the globe and loading completely but going to the blank gray screen and hanging. No options for Disk Utility or Reinstall OS, etc appear for either key combo. I hope that you can get your mac fixed! I know it's frustrating. – Z_z_Z Feb 16 at 22:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .