0

I have an external 2TB hard drive formatted with APFS connected to my 2017 iMac 27" running Mojave/10.14. Until yesterday, this external disk would be mounted during boot time and everything worked just fine.

Yesterday the system would start as normal but the drive would be unmounted after booting. But I could mount it with Disk Utility and use it as normal so I didn't think much about it.

Today the file system flipped to being read only. I rank Disk Utility on it and it said "deferred repairs" were done, and diskutil remounted the disk at the end but it was still read-only. I rebooted the entire system and the drive was not mounted after reboot. I mounted it with Disk Utility, and it's fully read/write again.

I have no idea what is going on. I just want it to work -- that is, have the disk me mounted read/write at boot time. When searching for solutions I run across a lot of "your HDD is formatted with NTFS that's why" and "just chmod 777 -R the entire disk" nonsense.

Other things (may or may not be related): I have been flipping to Windows 10 a lot recently (using BootCamp). Windows can't read the external HDD because it doesn't understand APFS.

  • Did you verify via command + i that ignore permission was set. Do you have a backup of this drive. I'd be worried. – historystamp Feb 16 at 0:22
  • I did, yes, and I do have a backup. – the_limey Feb 25 at 16:29
  • Hardware failing? Windows extra sauce added? Try using on a different machine. Install a new copy of macOS on a clean partition -- One that just been created or erased. See drive status. – historystamp Feb 25 at 20:24

You must log in to answer this question.

Browse other questions tagged .