-1

This is not a duplicate question.

I've already looked at the answers for Uninstalled zsh, terminal gone weird, and although I changed the settings, it still defaults back to zsh title, with a different prompt:

My terminal currently

And the preferences pane still defaults back to /bin/zsh, even after I change it to /usr/local/bin/bash and the Default login shell option, then restart my terminal:

Editing terminal settings

How can I fix this? I have tried restarting my computer and terminal, I have removed all zsh files...I am lost.

2

Because you are checking the "default login shell" option, Terminal will start your default login shell, which is apparently zsh. What you enter in the box below makes no difference, because you do not check that option.

You do not state what your goal is, but I will assume that it is to return to bash, which is the default in macOS.

To change your login shell back to bash:

  1. Open Settings (from the Apple menu).
  2. Select "Users and groups"
  3. Unlock it, if necessary, by clicking the padlock icon at the lower left and entering your password.
  4. Control-click your username in the list at the left, and select "Advanced" in the menu that appears.
  5. In the dialogue sheet that appears, change your login shell to /bin/bash.
1

To change it back to bash in terminal:

  1. Open terminal
  2. Type chsh -s /bin/bash USERNAME (this changes your shell)
  3. sudo chsh -s /bin/bash(this changes your root user shell)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .