1

I'm trying to move my time machine backup files all under Backups.backupdb to another drive. I initiated a file copy overnight. In the morning I saw that only certain backups(folders with dates) got copied over. I then tried to copy over the ones that didn't get copied...but the OS wouldn't allow me to do that. I got and error that "The operation can’t be completed because backup items can’t be modified."

So then I though, ok. I'll delete the incomplete copy from my new drive and then try to start a whole new copy.

I started the delete and it prepared all night (I can see it counting all the files in the delete dialogue box). HOWEVER, in the morning I saw the error "The operation can't be completed because unexpected error occurred (error code -8003).

I tried to search online for info about it and can't seem to find anything.

I also tried to hold down the OPTION key while emptying the trash and that didn't work. Holding down SHIFT+OPTION while emptying got me the -8003 error right away...I didn't have to wait for it to count all the files.

What is going on? How can I delete these files? I don't want to format my drive because it has other files on their that took a LONG time to copy.

2

I went through this just last week. Time Machine backups have ACL permissions set. There are a few ways to see these. The first is ls -e. This is from my TimeMachine .bash_profile

ls -le .bash_profile  
-rw-r--r--@ 5 gregcain  staff  6508 Mar 21 13:57 .bash_profile  
 0: group:everyone deny write,delete,append,writeattr,writeextattr,chown  

and this is for my normal one

ls -le .bash_profile  
-rw-r--r--  1 gregcain  staff  6748 Mar 29 13:08 .bash_profile  

If you want to modify these settings, you'll need chmod:

chmod -N .bash_profile
0

I've always found that Trash It! has helped when I need to delete something. I've not had to do it on an external disk, though.

Your alternative is to delete using the command line (sudo rm should override everything) Disclaimer:: you can do an immense amount of damage to your system using this so ensure you are deleting the right thing. This was on a related Apple Support Forums post - similar logic applies, except that the HDD will be mounted in /media/disk####### so you need to go there, and it wont be in .Trashes - it'll just be in the folder you put it in.

  • I'm trying it now and am using 'sudo rm -Rf' so that I wouldn't be prompted to confirm overrides. However, I'm getting tons of 'Operation not permitted' messages. Basically my terminal is constantly scrolling with these messages. The rm command is still running as I type this... – milesmeow Dec 31 '11 at 20:13
  • Do the errors contain things like '/tmbootpicker.efi: Operation not permitted' – markhunte Jun 10 '12 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .