0

I was trying to install Windows via BootCamp. But it showed an error and Bootcamp started to restore the partitions it created. But the process never finished so I had to quit BootCamp. I found out that the partition was not restored to MacOS so I tried to do it manually. I referred this page for that.

https://macreports.com/boot-camp-error-the-startup-disk-cannot-be-partitioned-or-restored-to-a-single-partition/

The partition got restored and I installed Windows again successfully. But when I tried to reboot in MacOS using BootCamp in Windows it showed "Could not locate OS X boot volume". I manually did a reboot to MacOS but I think I have messed up my disk. I have removed the Windows OS in Bootcamp. I am using MacOS Mojave.It used to show Macintosh HD in place of disk0s2 It used to show Macintosh HD in place of disk0s2.

This is the screenshot of Disk Utility. enter image description here Here are screenshots of diskutil cs list, diskutil list .

enter image description here

Any help would be greatly appreciated

  • The two issues are not related. Windows simply cannot see an APFS volume, so you have to switch by holding Alt at boot. – Tetsujin Feb 14 at 17:56
  • So core storage missing is not an issue? What about the name of the disk which is disk0s2 instead of Macintosh HD? – Sushmit Goyal Feb 15 at 8:37
  • Core Storage was used for Fusion drives. You have a single SSD by the look of it. You seem to be conflating several issues. Right now you have what looks like a standard single user partition, the others are system managed. – Tetsujin Feb 15 at 8:43
  • So there is nothing messed up here? – Sushmit Goyal Feb 15 at 10:26
  • No. Sounds like you had an issue with BC, fixed it & successfully then re-installed it. The only issue was that you didn't realise Windows can't read APFS, so you uninstalled it again. – Tetsujin Feb 15 at 10:35

You must log in to answer this question.

Browse other questions tagged .