I installed a new SSD, formatted it, and Mojave OS was installing when suddenly, the battery stopped charging. All I get now is a picture of a red battery with a low charge. If I remove the adapter, I get a picture that the adapter needs to be plugged in. I tried different outlets. I tried a different adapter. I don't get a green light on the adapters. Reset SMC. Reset Pram.

So it needs a new DC-In board or battery (which apple says is not removable) or both?

  • So did the battery ever charge after re-assembly (update the question in case you cannot comment)? For deeply discharged batteries it may take quite some time for the first few percent to charge. – n1000 Feb 13 '19 at 17:34
  • When I installed the new hard drive, the battery was really low. I plugged in the computer, and it was a good connection, and the battery was slowly charging. I formatted the new drive and Mojave OS was installing. I left it alone for maybe 30 minutes. When I came back to check on the installation the battery was dead and the charger wasn't working. I tried a different charger and outlets. – Kbunting Feb 15 '19 at 21:34

Browse other questions tagged .