4

I've faced with issue when sometimes after leaving sleep mode the iGPU is going into 200mhz instead normal 750mhz. The UI works slow, especially while you're switching desktops, scrolling in WebStorm and so on.

Here is some thermal data:

$ sudo thermal levels
cpu: 0
gpu: 0
io: 0

And some powermetrics:

$ sudo powermetrics -s gpu_power
Machine model: MacBookPro11,4
SMC version: 2.29f24
EFI version: 187.0.0
OS version: 18D109
Boot arguments:
Boot time: Mon Feb 11 13:59:37 2019



*** Sampled system activity (Tue Feb 12 17:39:04 2019 +0200) (5000.23ms elapsed) ***


**** GPU usage ****

GPU 0 name IntelIG
GPU 0 C-state residency: 98.22% (0.43%, 97.79%)
GPU 0 P-state residency: 1200MHz: 0.00%, 1150MHz: 0.00%, 1100MHz: 0.00%, 1050MHz: 0.00%, 1000MHz: 0.00%, 950MHz: 0.00%, 900MHz: 0.00%, 850MHz: 0.00%, 800MHz: 0.00%, 750MHz: 0.00%, 700MHz: 0.00%, 650MHz: 0.00%, 600MHz: 0.00%, 550MHz: 0.00%, 500MHz: 0.00%, 450MHz: 0.00%, 400MHz: 0.00%, 350MHz: 0.00%, 300MHz: 0.00%, 250MHz: 0.00%, 200MHz: 1.78%
GPU 0 average active frequency as fraction of nominal (200.00Mhz): 100.00% (200.00Mhz)
GPU 0 GPU Busy 1.78%
GPU 0 FB Test Case 0
GPU 0 [PSR] GPU + TCON are Off    : 0.00%
GPU 0 [PSR] Only GPU is On        : 100.00%
GPU 0 [PSR] Only TCON is On       : 0.00%
GPU 0 [PSR] GPU + TCON are On     : 0.00%
GPU 0 [PSR] Enter Count           : 0 (0.00/second)
GPU 0 [PSR] Abort Count           : 0 (0.00/second)
GPU 0 DPB on 0.00%
GPU 0 GT2 on 0.00%
GPU 0 GT3 on 100.00%

And here we go: 200MHz: 1.78%

And let me show iStat Menus output:

Screenshot

And only reboot is helpful. After reboot iGPU returns to 750mhz and UI works great. Is it the Apple's bug? Someone faced with the same issue? It's only about MacBook Pro 15" 2015 !! I have this issue on both (home laptop and on my work). Looks like I've faced it only on Mojave..

  • I have this exact same problem. 2015 MacBook Pro (with integrated GPU only), running Mojave. The GPU drops down to 200 mhz, often after waking up from sleep, and only a reboot will fix it. I'm also running WebStorm (and other JetBrains IDEs). Have you figured anything out since posting this? – Russell Davis Jul 15 at 3:41
  • 1
    You're running Build 18D09, which 10.14.3. Perhaps it's a problem that has been fixed in the OS updates since then? – benwiggy Jul 15 at 6:38
  • 1
    Typically GPUs underclock themselves when not in use. Have you tried resetting the SMC, NVRAM, and all that other stuff? – theuhdirector Jul 16 at 3:28
  • 1
    Several people have reported that blowing out the dust under the cover will fix thermal limiting. Not sure that's what is going on but it might be worth popping the cover off and giving it a good cleaning. – Thomas Nelson Jul 18 at 3:34
  • I have tried everything, including reseting SMC/NVRAM. Mm, I hadn't this issue for a long time. But last time I was playing with display scaling and again faced with 200mhz issue! Just a question to another guys here: are you playing with changing display scaling? Maybe this could be an issue. – Игорь Левченко Jul 25 at 12:46
0

The new 10.14.6 macOS update says it "resolves a graphics issue that may occur when waking from sleep". I'm hoping that might be referring to this issue (I filed an issue a few weeks ago at https://feedbackassistant.apple.com/, so that may have prompted them to look into it, though they haven't responded to it).

I'll update this answer if I see the problem again after the update.

UPDATE: I'm still seing the problem in 10.14.6 (as well as OP who commented below), so this is unfortunately not the solution.

  • 1
    When answering please focus on the problem described in the question. Issues with site functionality can and should be discussed on Ask Different Meta. – nohillside Jul 24 at 4:38
  • 2
    Unfortunately, I have faced with this issue again on 10.14.6. So, it's not a fix for an issue we are talking about. – Игорь Левченко Jul 25 at 12:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .